summaryrefslogtreecommitdiff
path: root/dev-util/uftrace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-02 22:43:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-02 22:43:17 +0000
commit44f7bdd4803ecacf7943d21fdf2531eb2ea9aeff (patch)
tree4710102399c8e8f01d716ea1139c8fd2db449d7d /dev-util/uftrace
parent417ef5d7c7bd36af15766ab14554600fbe7daed7 (diff)
gentoo auto-resync : 02:02:2025 - 22:43:16
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/Manifest2
-rw-r--r--dev-util/uftrace/uftrace-0.17.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/uftrace/Manifest b/dev-util/uftrace/Manifest
index f15988e59d73..d91639092a75 100644
--- a/dev-util/uftrace/Manifest
+++ b/dev-util/uftrace/Manifest
@@ -1,3 +1,5 @@
DIST uftrace-0.16.tar.gz 1157903 BLAKE2B d79471cc1780f52983adfd40fa726190a70a0ecff900a9059d6963cd893f93c679f3626dd388b5dc17b7cc94a276a086b29b1398fd1270f593d49e5919eae650 SHA512 509fc42369cd495fb12e492b6c7726b0f26fa22bcb87452efc36b232a4bf999ff08c69829ad413ecf2c194e3564cf89f7634cfa03d0427926ee62aa957bacd5b
+DIST uftrace-0.17.tar.gz 1164457 BLAKE2B 7e9ed9af07d9f2ca8b78d7b7651408f5065917207c57855e6486c6d0d8acdaf3f87096a789f74e4458705c2fd59393fb6973f8e43750bc0bb4e3ab56268e6177 SHA512 b76ac32e68b474522f7d9c470940093bc37cf5d3d2d119d10ffad2954262e83c4092f593f307a41c765a6975416bfc62b844436a4d1888639741eb328e16e1d8
EBUILD uftrace-0.16.ebuild 1502 BLAKE2B b2d0cdc9d23d7d44613d50f99a2c8fa8bda5730ca812c1bf063a872bee0b63000b52f4ccc3c270da465fe8f3ff1aee6a8e3de5162bd960ad1c99a3d17cb8e109 SHA512 85053095466b8ba78d873b2c1e336fbd3a5548a6e761d5cbec23166b230157056e8a59c03c313cf1fb7c73611cee59e318efce725a0567c85d84ec9a53ad353f
+EBUILD uftrace-0.17.ebuild 1539 BLAKE2B da87c9c8b35b46ac82d12b539692878c9c83f150b680064dfe8c2390bd14dc491e24e59f9bc751467c5319c226befd761e784992043dc432651acf6e880ba8a9 SHA512 128da60ad41cf963369cea3bd56a7ad0f7801c9a88a57861ba825ddd3db4098b4b04587c5aff38a7397e2ca15e65293e0e860d7db27a61db8680e4b3c1978b45
MISC metadata.xml 439 BLAKE2B 5164074d22c56fcba8f0677446484c392c347058c444e3f2760cc1e6d17e07406741f80a525ba99b575dca2d9347fe3b13b82fe5aa79bc734add9806695a5fe2 SHA512 d6e0f7ab729d6088748d5efe5c88910355f5ab7e70308b3b24f8cd27956b0ee21f8ff8bce18f9969694bd4677c229fe80317735de63e9a80b4dca638738dbe5d
diff --git a/dev-util/uftrace/uftrace-0.17.ebuild b/dev-util/uftrace/uftrace-0.17.ebuild
new file mode 100644
index 000000000000..e41ed3fc8197
--- /dev/null
+++ b/dev-util/uftrace/uftrace-0.17.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{9..13} ) # fails to compile with python3.13t
+
+inherit bash-completion-r1 flag-o-matic lua-single python-single-r1 toolchain-funcs
+
+DESCRIPTION="Function (graph) tracer for user-space"
+HOMEPAGE="https://github.com/namhyung/uftrace"
+SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="capstone lua python unwind"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libelf:=
+ capstone? ( dev-libs/capstone:0= )
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+ unwind? ( sys-libs/libunwind:= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
+}
+
+src_configure() {
+ # bug #858503 (https://github.com/namhyung/uftrace/issues/1343)
+ filter-lto
+
+ local myconf=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)/uftrace"
+ $(use_with capstone)
+ $(use_with unwind libunwind)
+ $(use_with python libpython)
+ )
+ if use lua && use lua_single_target_luajit; then
+ myconf+=(
+ --with-libluajit
+ )
+ else
+ myconf+=(
+ --without-libluajit
+ )
+ fi
+ CC="$(tc-getCC)" LD="$(tc-getLD)" econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ dodoc doc/*.{md,gif,png}
+ newbashcomp misc/bash-completion.sh uftrace
+}