summaryrefslogtreecommitdiff
path: root/dev-util/unicorn/unicorn-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/unicorn/unicorn-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/unicorn/unicorn-9999.ebuild')
-rw-r--r--dev-util/unicorn/unicorn-9999.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-util/unicorn/unicorn-9999.ebuild b/dev-util/unicorn/unicorn-9999.ebuild
index 8687e522b5a0..01c1ff6ba6bf 100644
--- a/dev-util/unicorn/unicorn-9999.ebuild
+++ b/dev-util/unicorn/unicorn-9999.ebuild
@@ -23,7 +23,7 @@ fi
S="${WORKDIR}/${PN}-${MY_PV}"
-LICENSE="GPL-2"
+LICENSE="BSD-2 GPL-2 LGPL-2.1"
SLOT="0/2"
IUSE="python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -31,16 +31,10 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="${PYTHON_DEPS}
dev-libs/glib:2"
RDEPEND="python? ( ${PYTHON_DEPS} )"
-# See bug #832337 re Python deps
BDEPEND="virtual/pkgconfig
- python? (
- >=dev-python/installer-0.4.0_p20220124[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
- >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
+ python? ( ${DISTUTILS_DEPS} )"
-UNICORN_TARGETS="x86 arm aarch64 riscv mips sparc m68k ppc"
+UNICORN_TARGETS="x86 arm aarch64 riscv mips sparc m68k ppc s390x"
wrap_python() {
if use python; then
@@ -64,9 +58,8 @@ src_prepare() {
src_configure(){
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DUNICORN_BUILD_SHARED=$(usex !static-libs)
- -DUNICORN_ARCH="${UNICORN_TARGETS}"
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DUNICORN_ARCH="${UNICORN_TARGETS// /;}"
)
cmake_src_configure