summaryrefslogtreecommitdiff
path: root/dev-util/unifdef/unifdef-2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/unifdef/unifdef-2.11.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/unifdef/unifdef-2.11.ebuild')
-rw-r--r--dev-util/unifdef/unifdef-2.11.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-util/unifdef/unifdef-2.11.ebuild b/dev-util/unifdef/unifdef-2.11.ebuild
new file mode 100644
index 000000000000..f28f46c74f52
--- /dev/null
+++ b/dev-util/unifdef/unifdef-2.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
+HOMEPAGE="http://dotat.at/prog/unifdef/"
+SRC_URI="http://dotat.at/prog/unifdef/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -sparc-fbsd -x86-fbsd ~amd64-linux ~x86-linux"
+
+DOCS=( README )
+
+src_prepare() {
+ sed -i "/^prefix/s:=.*:=${EPREFIX}/usr:" Makefile || die
+ tc-export CC
+}