summaryrefslogtreecommitdiff
path: root/dev-util/unifdef/unifdef-2.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 06:19:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 06:19:57 +0000
commit30f491533785a455cdfbd05bb57f1f869a8e41bb (patch)
tree231d01a9349dfa1f56a7235017f5201a7382c652 /dev-util/unifdef/unifdef-2.12-r1.ebuild
parenta96f1a2ca235a5eb9e7c498636cd1291be76cb09 (diff)
gentoo auto-resync : 10:01:2023 - 06:19:57
Diffstat (limited to 'dev-util/unifdef/unifdef-2.12-r1.ebuild')
-rw-r--r--dev-util/unifdef/unifdef-2.12-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/unifdef/unifdef-2.12-r1.ebuild b/dev-util/unifdef/unifdef-2.12-r1.ebuild
new file mode 100644
index 000000000000..f11d421c48d1
--- /dev/null
+++ b/dev-util/unifdef/unifdef-2.12-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
+HOMEPAGE="https://dotat.at/prog/unifdef/"
+SRC_URI="https://dotat.at/prog/unifdef/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+DOCS=( README )
+
+src_prepare() {
+ sed -i "/^prefix/s:=.*:=${EPREFIX}/usr:" Makefile || die
+ tc-export CC
+ default
+}