summaryrefslogtreecommitdiff
path: root/dev-util/w32api
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/w32api
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/w32api')
-rw-r--r--dev-util/w32api/Manifest5
-rw-r--r--dev-util/w32api/metadata.xml11
-rw-r--r--dev-util/w32api/w32api-3.17.2.ebuild65
-rw-r--r--dev-util/w32api/w32api-4.0.3.1.ebuild67
4 files changed, 148 insertions, 0 deletions
diff --git a/dev-util/w32api/Manifest b/dev-util/w32api/Manifest
new file mode 100644
index 000000000000..7740d6eb6b29
--- /dev/null
+++ b/dev-util/w32api/Manifest
@@ -0,0 +1,5 @@
+DIST w32api-3.17-2-mingw32-src.tar.lzma 965844 BLAKE2B 9dec25676f57dd7886f83871fee2186e3f9750eba620492aa43e7eeb58e402506c7d30bbd71c26c59c0d2c97b2aff25ffade00df8a3cc7b8835b803da8172045 SHA512 4fc8f319ab895366fb3757713e2724f8f4c90593687f1ccfdbfa6a52881ddc430167326e782117ae937c7e456e029132b971c3a041889bcfb876a84741475a1f
+DIST w32api-4.0.3-1-mingw32-src.tar.lzma 1341804 BLAKE2B cd7811b1291775926b15128b5c5f126ab09b9f7e824d7cf24210473c09563cfc06b3aaea40459502869e4df45d2b5af311b8d14b2bdaf793be483a5c80571fe7 SHA512 9295b7e803b1551dfefbf527e98fa315d60c70f6b63b4565942f7bc3d6032483d5ec4f76265b376fc6776c5ecfd1ad47fd912764c390b0b6917b1ad382250977
+EBUILD w32api-3.17.2.ebuild 1498 BLAKE2B 66f97f967519205d73a8d4a4d14e2b7f8fee1d3c26486fc64e01f9dd8435e968704c613912a126b97a7de1692e41d7d8e067d7c760c5a1d0bf2bcfcf896821dd SHA512 7a6ecfd504b3c82ce7eb7231848680aa00c94c2faea38eb5ab77c039f7716b46aa61a143a876555c57afd80fdd08069a8ffb95511ac750ddee0309aa8034b613
+EBUILD w32api-4.0.3.1.ebuild 1598 BLAKE2B a7039078b084d49eb8438bcd3f3f4df18ded5e0ef8ae10cb976ad9e20b5a50b36bf2303d4d0e0b28fb2ff89fcb7d6b34a1e330aee81e5b451b451371dcd0a212 SHA512 02c252e36293780ff567cfc59dffb93f8ef914bd2eb396e4f40d7880d515ee77a2b5a007baf6e2167715c86c3482f6ba656e2f81bb6b5acc0745335c27e0e622
+MISC metadata.xml 336 BLAKE2B f5b695f0c70efe0aef9843aab32d906407185d04d70d0ca5dc63872ec3f30d08454f4c706ade2f5d6191ac39cb0c3252349f03a50cf9c1726562361634e7d928 SHA512 c15c4f7fe2796147558f99a89942b216159b291e18dfb02358f0985fef55e7ce166dbd0831ef24938a5bc76377634036932e0ce1526d01c2b07be35cac17cbf9
diff --git a/dev-util/w32api/metadata.xml b/dev-util/w32api/metadata.xml
new file mode 100644
index 000000000000..6c377f90be9b
--- /dev/null
+++ b/dev-util/w32api/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>toolchain@gentoo.org</email>
+ <name>Gentoo Toolchain Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mingw</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/w32api/w32api-3.17.2.ebuild b/dev-util/w32api/w32api-3.17.2.ebuild
new file mode 100644
index 000000000000..02fce8e4df78
--- /dev/null
+++ b/dev-util/w32api/w32api-3.17.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+inherit eutils flag-o-matic
+
+MY_P="${P:0:${#P}-2}-${PV:0-1}-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+# https://sourceforge.net/projects/mingw/files/MinGW/Base/w32api/
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.lzma"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="headers-only"
+RESTRICT="strip"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+just_headers() {
+ use headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration; do not emerge this directly"
+ fi
+}
+
+src_compile() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ econf \
+ --host=${CTARGET} \
+ --prefix=/usr/${CTARGET}/usr
+ emake || die
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/* || die
+ else
+ emake install DESTDIR="${D}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
+
+ # Make sure diff cross-compilers don't collide #414075
+ mv "${D}"/usr/share/doc/{${PF},${CTARGET}-${PF}} || die
+ fi
+}
diff --git a/dev-util/w32api/w32api-4.0.3.1.ebuild b/dev-util/w32api/w32api-4.0.3.1.ebuild
new file mode 100644
index 000000000000..26a1f1cb5bf2
--- /dev/null
+++ b/dev-util/w32api/w32api-4.0.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${P:0:${#P}-2}-${PV:0-1}-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+# https://sourceforge.net/projects/mingw/files/MinGW/Base/w32api/
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.lzma"
+
+LICENSE="BSD"
+SLOT="0"
+# Collides with mingw-runtime-4.x
+#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="headers-only"
+RESTRICT="strip"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P/-m/.m}-src
+
+just_headers() {
+ use headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration; do not emerge this directly"
+ fi
+}
+
+src_configure() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ filter-flags -frecord-gcc-switches
+ tc-export AR
+ econf \
+ --host=${CTARGET} \
+ --prefix=/usr/${CTARGET}/usr \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/*
+ else
+ emake -j1 install DESTDIR="${D}"
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+
+ # Make sure diff cross-compilers don't collide #414075
+ mv "${D}"/usr/share/doc/{${PF},${CTARGET}-${PF}} || die
+ fi
+}