summaryrefslogtreecommitdiff
path: root/dev-util/xdelta/xdelta-1.1.4-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-26 01:01:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-26 01:01:01 +0000
commit970b06af05f42e54a47439caaa9bd9a31ee30142 (patch)
tree7d58838b2008550a4c1d06b306efafa0e4624542 /dev-util/xdelta/xdelta-1.1.4-r4.ebuild
parentfc68863e718441fe15bb0dea2ca03ea06a6f558d (diff)
gentoo auto-resync : 26:03:2024 - 01:01:01
Diffstat (limited to 'dev-util/xdelta/xdelta-1.1.4-r4.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-1.1.4-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-1.1.4-r4.ebuild b/dev-util/xdelta/xdelta-1.1.4-r4.ebuild
new file mode 100644
index 000000000000..b632f97574e6
--- /dev/null
+++ b/dev-util/xdelta/xdelta-1.1.4-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Computes changes between binary or text files and creates deltas"
+HOMEPAGE="https://xdelta.googlecode.com/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-m4.patch"
+ "${FILESDIR}/${P}-glib2.patch"
+ "${FILESDIR}/${P}-pkgconfig.patch"
+ "${FILESDIR}/${P}-gzip.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}