summaryrefslogtreecommitdiff
path: root/dev-util/yamllint/yamllint-1.27.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 01:35:20 +0100
commitc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (patch)
tree32b0c57abadad13ba25305af959e636eb410bee0 /dev-util/yamllint/yamllint-1.27.1.ebuild
parentad4a5451f677f33e2de05548b45fb92a8b3d04da (diff)
gentoo auto-resync : 13:07:2022 - 01:35:20
Diffstat (limited to 'dev-util/yamllint/yamllint-1.27.1.ebuild')
-rw-r--r--dev-util/yamllint/yamllint-1.27.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/yamllint/yamllint-1.27.1.ebuild b/dev-util/yamllint/yamllint-1.27.1.ebuild
new file mode 100644
index 000000000000..7ebbb2e782d0
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.27.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest