summaryrefslogtreecommitdiff
path: root/dev-util/yamllint/yamllint-1.31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 17:46:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 17:46:59 +0100
commit54654470d999265b5a0010be7190e8a9993b1840 (patch)
treecb6b99a56837c648a69859da9333e5b9a726912d /dev-util/yamllint/yamllint-1.31.0.ebuild
parent2046683958d0497bec1458741dc867558b69e622 (diff)
gentoo auto-resync : 11:05:2023 - 17:46:59
Diffstat (limited to 'dev-util/yamllint/yamllint-1.31.0.ebuild')
-rw-r--r--dev-util/yamllint/yamllint-1.31.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/yamllint/yamllint-1.31.0.ebuild b/dev-util/yamllint/yamllint-1.31.0.ebuild
new file mode 100644
index 000000000000..49b3567c1eda
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.31.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest