summaryrefslogtreecommitdiff
path: root/dev-util/yamllint/yamllint-1.32.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 03:04:18 +0100
commit4bc145ba9c79d57abcafc9b97c72bd5addd3e833 (patch)
tree6d3232c40367527f41a16208e51be62072e72efc /dev-util/yamllint/yamllint-1.32.0.ebuild
parentcc6fb501ef0f4c443ce79d017dbfbd95072b14f4 (diff)
gentoo auto-resync : 25:05:2023 - 03:04:17
Diffstat (limited to 'dev-util/yamllint/yamllint-1.32.0.ebuild')
-rw-r--r--dev-util/yamllint/yamllint-1.32.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/yamllint/yamllint-1.32.0.ebuild b/dev-util/yamllint/yamllint-1.32.0.ebuild
new file mode 100644
index 000000000000..49b3567c1eda
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.32.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest