summaryrefslogtreecommitdiff
path: root/dev-util/ydiff/ydiff-1.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 04:19:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 04:19:48 +0000
commit639971d0c3ee4eef36854ab7d9729b6e8c3ac1cb (patch)
treeb91746d94af21bb8d8ea07ac19b0ef7e61a54ce3 /dev-util/ydiff/ydiff-1.2-r2.ebuild
parent0e3680e4c16ff28839745eec6711889fc2e8d7e2 (diff)
gentoo auto-resync : 07:11:2023 - 04:19:48
Diffstat (limited to 'dev-util/ydiff/ydiff-1.2-r2.ebuild')
-rw-r--r--dev-util/ydiff/ydiff-1.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/ydiff/ydiff-1.2-r2.ebuild b/dev-util/ydiff/ydiff-1.2-r2.ebuild
new file mode 100644
index 000000000000..3f16531fa948
--- /dev/null
+++ b/dev-util/ydiff/ydiff-1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer (ex. cdiff)"
+HOMEPAGE="https://github.com/ymattw/ydiff"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-apps/less"
+
+DOCS=( CHANGES.rst README.rst )
+
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} tests/test_ydiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}