summaryrefslogtreecommitdiff
path: root/dev-util/ydiff/ydiff-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/ydiff/ydiff-1.2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/ydiff/ydiff-1.2.ebuild')
-rw-r--r--dev-util/ydiff/ydiff-1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/ydiff/ydiff-1.2.ebuild b/dev-util/ydiff/ydiff-1.2.ebuild
new file mode 100644
index 000000000000..d3dfb7dd60a0
--- /dev/null
+++ b/dev-util/ydiff/ydiff-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer (ex. cdiff)"
+HOMEPAGE="https://github.com/ymattw/ydiff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sys-apps/less"
+RDEPEND=""
+
+DOCS=( CHANGES.rst README.rst )
+
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} tests/test_ydiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}