summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 19:38:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 19:38:44 +0100
commit17ba30fcfb7751f08296c8e4caa05f20bb0813c5 (patch)
tree1228745a8930693aa1b707f9882a9785ca63bff3 /dev-util
parent1919539ec916b166ea3a7b6c5778c40d5bccad70 (diff)
gentoo auto-resync : 28:06:2023 - 19:38:44
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin68461 -> 68462 bytes
-rw-r--r--dev-util/perf/Manifest1
-rw-r--r--dev-util/perf/perf-6.3-r1.ebuild276
3 files changed, 277 insertions, 0 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index b86de9d99cc6..bbdc696821d7 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/perf/Manifest b/dev-util/perf/Manifest
index 4c3ebd7b9060..0a8edac5d12a 100644
--- a/dev-util/perf/Manifest
+++ b/dev-util/perf/Manifest
@@ -9,5 +9,6 @@ DIST perf-5.19-binutils-2.39-patches.tar.xz 5612 BLAKE2B ec3aeadc3e2508f33dddbb4
EBUILD perf-5.19-r1.ebuild 8102 BLAKE2B 105241021a13e62d86ba42b1108b1dd1ea5fa87fd95bd18b96d3c54a4b4d0582e3cbeb4307d73f912d1c88713e46afeb6f2736e4d34a9619fab44ce6c2828b93 SHA512 762b2e1c7ff5fc89194f4c08581a9594735f744cfb8e6bd165a31468544f3f59c67224e95dad675c7047162beea6b246d5ffb7f20b052cf8485da6c28780340d
EBUILD perf-6.0-r1.ebuild 7560 BLAKE2B 0921a84f1138896c749c45097e100ed27ec5fd70901263ac0a04fd9e8b60bd3f748ab8fb815b480c36d53929b21d9511c1718955ca81b1a24307fe8daf762aa7 SHA512 4cca761f3007eb79d9cd9211dfa29bb967447d2c8c2374260674952e0d37180289cf592f50ae39c1b09de9e3f44f3fce2d032c854b50b5318a25ad9f4609f584
EBUILD perf-6.2-r1.ebuild 7564 BLAKE2B 3faaa7be0ee20a2f26617e6724a8db6b9a6dcec163b69f9fef640ed4727462aaf7e63231046d7d0c5988577c591d3ad1c898812d230c3b949774d4a177864af5 SHA512 f8c4ac3b7c2847a94b833b4fad898afc1e738de11b6e28e1c15136ca40217b57985143dd781ae99a0d5a938708dca2d8bcf6b66d03241a0766e9f3fbe652c189
+EBUILD perf-6.3-r1.ebuild 7568 BLAKE2B 301182f64188210ed3abf7d903557b79f5c0cc469c61f3ad407d09999afd946b0267a2a286af0f1089f77ecb388e9ed29a1caefcc2ad9a7ff6bda6ccd5b61694 SHA512 cafe7e439f1da10bd6f3ef48f1b3b9cd01d0d0e39e5b30339a22e9f9b90762f5081917bea696b0beacba49a889c21e4b331ab27b033c26333f1108395ae99722
EBUILD perf-6.3.ebuild 7558 BLAKE2B d15f100dcfa7d1f4f567f76a2bc375ed81ea2e71ebf54d28bead8577b905233545e229d31be84ce4edccb5aa039064146c02eea307ea514bdab9b605f78f2299 SHA512 7492001c2466083504f7406face29631814c4104459a5b21acd650a6261328ed0b9132d23117438b931b2dd80c27843263d2d97c85b98ab1e84801edc8d393c0
MISC metadata.xml 1381 BLAKE2B 99d6c9db46b79ad7abd993c123f826dbe3f5e7c33fea98139a7fc694fe4d81e67887873e9edb390d63e65ca351033a8bd62d799fac946e2334188c2a4b776328 SHA512 a952ee2f4173bd2957038614c6ebaa44ff20bcf57f83f8fc5eabbaced667a7254a3e326e0fca541f1ce10bcc4e1d0df0b46600268bf38baf39bb2dda2bb3e41d
diff --git a/dev-util/perf/perf-6.3-r1.ebuild b/dev-util/perf/perf-6.3-r1.ebuild
new file mode 100644
index 000000000000..eb28c4419c9b
--- /dev/null
+++ b/dev-util/perf/perf-6.3-r1.ebuild
@@ -0,0 +1,276 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 estack llvm toolchain-funcs python-r1 linux-info
+
+DESCRIPTION="Userland tools for Linux Performance Counters"
+HOMEPAGE="https://perf.wiki.kernel.org/"
+
+LINUX_V="${PV:0:1}.x"
+if [[ ${PV} == *_rc* ]] ; then
+ LINUX_VER=$(ver_cut 1-2).$(($(ver_cut 3)-1))
+ PATCH_VERSION=$(ver_cut 1-3)
+ LINUX_PATCH=patch-${PV//_/-}.xz
+ SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
+ https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
+elif [[ ${PV} == *.*.* ]] ; then
+ # stable-release series
+ LINUX_VER=$(ver_cut 1-2)
+ LINUX_PATCH=patch-${PV}.xz
+ SRC_URI="https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
+else
+ LINUX_VER=${PV}
+ SRC_URI=""
+fi
+
+LINUX_SOURCES="linux-${LINUX_VER}.tar.xz"
+SRC_URI+=" https://www.kernel.org/pub/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="audit babeltrace caps clang crypt debug +doc gtk java libpfm lzma numa perl python slang systemtap unwind zstd"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# setuptools (and Python) are always needed even if not building Python bindings
+BDEPEND="
+ ${LINUX_PATCH+dev-util/patchutils}
+ ${PYTHON_DEPS}
+ >=app-arch/tar-1.34-r2
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ doc? (
+ app-text/asciidoc
+ app-text/sgml-common
+ app-text/xmlto
+ sys-process/time
+ )
+"
+
+RDEPEND="
+ audit? ( sys-process/audit )
+ babeltrace? ( dev-util/babeltrace )
+ caps? ( sys-libs/libcap )
+ clang? (
+ sys-devel/clang:=
+ sys-devel/llvm:=
+ )
+ crypt? ( dev-libs/openssl:= )
+ gtk? ( x11-libs/gtk+:2 )
+ java? ( virtual/jre:* )
+ libpfm? ( dev-libs/libpfm:= )
+ lzma? ( app-arch/xz-utils )
+ numa? ( sys-process/numactl )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ slang? ( sys-libs/slang )
+ systemtap? ( dev-util/systemtap )
+ unwind? ( sys-libs/libunwind:= )
+ zstd? ( app-arch/zstd:= )
+ dev-libs/elfutils
+ sys-libs/binutils-libs:=
+ sys-libs/zlib
+"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-5.10
+ java? ( virtual/jdk )
+"
+
+S_K="${WORKDIR}/linux-${LINUX_VER}"
+S="${S_K}/tools/perf"
+
+CONFIG_CHECK="~PERF_EVENTS ~KALLSYMS"
+
+QA_FLAGS_IGNORED=(
+ 'usr/bin/perf-read-vdso32' # not linked with anything except for libc
+ 'usr/libexec/perf-core/dlfilters/.*' # plugins
+)
+
+pkg_pretend() {
+ if ! use doc ; then
+ ewarn "Without the doc USE flag you won't get any documentation nor man pages."
+ ewarn "And without man pages, you won't get any --help output for perf and its"
+ ewarn "sub-tools."
+ fi
+}
+
+pkg_setup() {
+ use clang && llvm_pkg_setup
+ # We enable python unconditionally as libbpf always generates
+ # API headers using python script
+ python_setup
+}
+
+# src_unpack and src_prepare are copied to dev-util/bpftool since
+# it's building from the same tarball, please keep it in sync with bpftool
+src_unpack() {
+ local paths=(
+ tools/arch tools/build tools/include tools/lib tools/perf tools/scripts
+ scripts include lib "arch/*/lib"
+ )
+
+ # We expect the tar implementation to support the -j option (both
+ # GNU tar and libarchive's tar support that).
+ echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
+ gtar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
+ "${paths[@]/#/linux-${LINUX_VER}/}" || die
+
+ if [[ -n ${LINUX_PATCH} ]] ; then
+ eshopts_push -o noglob
+ ebegin "Filtering partial source patch"
+ filterdiff -p1 ${paths[@]/#/-i } -z "${DISTDIR}"/${LINUX_PATCH} \
+ > ${P}.patch
+ eend $? || die "filterdiff failed"
+ eshopts_pop
+ fi
+
+ local a
+ for a in ${A}; do
+ [[ ${a} == ${LINUX_SOURCES} ]] && continue
+ [[ ${a} == ${LINUX_PATCH} ]] && continue
+ unpack ${a}
+ done
+}
+
+src_prepare() {
+ default
+ if [[ -n ${LINUX_PATCH} ]] ; then
+ pushd "${S_K}" >/dev/null || die
+ eapply "${WORKDIR}"/${P}.patch
+ popd || die
+ fi
+
+ pushd "${S_K}" >/dev/null || die
+ eapply "${FILESDIR}"/perf-6.0-clang.patch
+ eapply "${FILESDIR}"/perf-6.0-c++17.patch
+ popd || die
+
+ # Drop some upstream too-developer-oriented flags and fix the
+ # Makefile in general
+ sed -i \
+ -e "s@\$(sysconfdir_SQ)/bash_completion.d@$(get_bashcompdir)@" \
+ "${S}"/Makefile.perf || die
+ # A few places still use -Werror w/out $(WERROR) protection.
+ sed -i -e 's@-Werror@@' \
+ "${S}"/Makefile.perf "${S_K}"/tools/lib/bpf/Makefile \
+ "${S_K}"/tools/lib/perf/Makefile || die
+
+ # Avoid the call to make kernelversion
+ sed -i -e '/PERF-VERSION-GEN/d' Makefile.perf || die
+ echo "#define PERF_VERSION \"${PV}\"" > PERF-VERSION-FILE
+
+ # The code likes to compile local assembly files which lack ELF markings.
+ find -name '*.S' -exec sed -i '$a.section .note.GNU-stack,"",%progbits' {} +
+}
+
+puse() { usex $1 "" no; }
+perf_make() {
+ # The arch parsing is a bit funky. The perf tools package is integrated
+ # into the kernel, so it wants an ARCH that looks like the kernel arch,
+ # but it also wants to know about the split value -- i386/x86_64 vs just
+ # x86. We can get that by telling the func to use an older linux version.
+ # It's kind of a hack, but not that bad ...
+
+ # LIBDIR sets a search path of perf-gtk.so. Bug 515954
+
+ local arch=$(tc-arch-kernel)
+ local java_dir
+ use java && java_dir="${EPREFIX}/etc/java-config-2/current-system-vm"
+ # FIXME: NO_CORESIGHT
+ local emakeargs=(
+ V=1 VF=1
+ HOSTCC="$(tc-getBUILD_CC)" HOSTLD="$(tc-getBUILD_LD)"
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" AR="$(tc-getAR)" LD="$(tc-getLD)" NM="$(tc-getNM)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ prefix="${EPREFIX}/usr" bindir_relative="bin"
+ tipdir="share/doc/${PF}"
+ EXTRA_CFLAGS="${CFLAGS}"
+ EXTRA_LDFLAGS="${LDFLAGS}"
+ ARCH="${arch}"
+ JDIR="${java_dir}"
+ LIBCLANGLLVM=$(usex clang 1 "")
+ LIBPFM4=$(usex libpfm 1 "")
+ NO_AUXTRACE=""
+ NO_BACKTRACE=""
+ NO_CORESIGHT=1
+ NO_DEMANGLE=
+ GTK2=$(usex gtk 1 "")
+ feature-gtk2-infobar=$(usex gtk 1 "")
+ NO_JVMTI=$(puse java)
+ NO_LIBAUDIT=$(puse audit)
+ NO_LIBBABELTRACE=$(puse babeltrace)
+ NO_LIBBIONIC=1
+ NO_LIBBPF=
+ NO_LIBCAP=$(puse caps)
+ NO_LIBCRYPTO=$(puse crypt)
+ NO_LIBDW_DWARF_UNWIND=
+ NO_LIBELF=
+ NO_LIBNUMA=$(puse numa)
+ NO_LIBPERL=$(puse perl)
+ NO_LIBPYTHON=$(puse python)
+ NO_LIBUNWIND=$(puse unwind)
+ NO_LIBZSTD=$(puse zstd)
+ NO_SDT=$(puse systemtap)
+ NO_SLANG=$(puse slang)
+ NO_LZMA=$(puse lzma)
+ NO_ZLIB=
+ WERROR=0
+ LIBDIR="/usr/libexec/perf-core"
+ libdir="${EPREFIX}/usr/$(get_libdir)"
+ plugindir="${EPREFIX}/usr/$(get_libdir)/perf/plugins"
+ "$@"
+ )
+ emake "${emakeargs[@]}"
+}
+
+src_compile() {
+ # test-clang.bin not build with g++
+ if use clang; then
+ make -C "${S_K}/tools/build/feature" V=1 CXX=${CHOST}-clang++ test-clang.bin || die
+ fi
+ perf_make -f Makefile.perf
+ use doc && perf_make -C Documentation man
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ _install_python_ext() {
+ perf_make -f Makefile.perf install-python_ext DESTDIR="${D}"
+ }
+
+ perf_make -f Makefile.perf install DESTDIR="${D}"
+
+ if use python; then
+ python_foreach_impl _install_python_ext
+ fi
+
+ if use gtk; then
+ local libdir
+ libdir="$(get_libdir)"
+ # on some arches it ends up in lib even on 64bit, ppc64 for instance.
+ [[ -f "${ED}"/usr/lib/libperf-gtk.so ]] && libdir="lib"
+ mv "${ED}"/usr/${libdir}/libperf-gtk.so \
+ "${ED}"/usr/libexec/perf-core || die
+ fi
+
+ dodoc CREDITS
+
+ dodoc *txt Documentation/*.txt
+
+ # perf needs this decompressed to print out tips for users
+ docompress -x /usr/share/doc/${PF}/tips.txt
+
+ if use doc ; then
+ doman Documentation/*.1
+ fi
+}