summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 07:01:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 07:01:01 +0000
commit2c9b8fbe41c04a94054b0540b54fcf2de0b79166 (patch)
treee83313a8db0bba5ca6d288977a45bbdf0dea81c9 /dev-util
parent6c169675dd21d25ad82ab0560f3d5b1e714219b6 (diff)
gentoo auto-resync : 23:03:2024 - 07:01:01
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin65101 -> 65102 bytes
-rw-r--r--dev-util/blueprint-compiler/Manifest2
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild74
-rw-r--r--dev-util/ruff/Manifest1
-rw-r--r--dev-util/ruff/files/0001-Gate-f-string-struct-size-test-for-Rustc-1.76-10371.patch29
5 files changed, 76 insertions, 30 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 8127be7dfff4..91dbe84d8cab 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index 85558e47729d..3c0bf02d663b 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1,3 +1,5 @@
DIST blueprint-compiler-v0.10.0.tar.bz2 81856 BLAKE2B 8e63c27fc160244eb11776ea57c57b9c4b06aded76f3d59fc3190609f20a58985e3e800eebb5c69e681f8f8aba35f06f457f4dde241f78ff76d3e9348c4df46d SHA512 5d6a14a42aed64a82572a59730d454a920938d3b2c8aa1e61ab1d5fba47647ab5e3d6201c8ffe3e622b450ffcfb1eaf106951489897422c3e578d4d3695ae9ab
+DIST blueprint-compiler-v0.12.0.tar.bz2 90521 BLAKE2B 0c54f287c2d9e6869f323981eaff16785aa4fa7b1c600629bccde059205950f70f2202642130500133c69235ce42abfb5b5492a5727da561db9fe6c865939bb8 SHA512 c1f2f1ab02773b8c9c1d92035a51cd3b5c769a129ea028e02b8d2d88a7a9cb44f14edefd0f8718b90313a22134d8cbab4f699942f7049edd3146b41735e68f56
EBUILD blueprint-compiler-0.10.0.ebuild 1438 BLAKE2B 56cbcbe4622e0f2fc95ec8e7eade565114b8b492e8b551d9537cf667a1391e103fb978928beccf6e98cd67afb9ce45cbeedab53c81c165e84263b2d199d5a708 SHA512 3fcd96861116130252036a18d1522411d810ae2cf8b08bc169306a0c4bab358caee8d1e095495d2779959ded0b374a55e3a7599f4a44823104560f377b12bd2c
+EBUILD blueprint-compiler-0.12.0.ebuild 1441 BLAKE2B cdb8a191cd387ce7f78200a1a2178360e48daf9b7412989737ae0ac2bffafce268486f2cb692cbca7e25a844c9fefaf46c25f1b7995a54ae463abe1bc603a160 SHA512 48dd10503dfc6e4d1f3c03ffe047028e811ccc2315783700fb14b73b53b7f7df7a15eeea7dfd68367d22e082f61b2335c8d484a6767597115a14e2e2c4290c2e
MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
new file mode 100644
index 000000000000..7690faf1230b
--- /dev/null
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 virtualx
+
+DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
+HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
+ https://gitlab.gnome.org/jwestman/blueprint-compiler/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
+else
+ SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-v${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/furo[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ )
+"
+
+DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use doc docs)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ use doc && build_sphinx docs
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize
+}
diff --git a/dev-util/ruff/Manifest b/dev-util/ruff/Manifest
index 7a15603f58a9..da4275d10690 100644
--- a/dev-util/ruff/Manifest
+++ b/dev-util/ruff/Manifest
@@ -1,4 +1,3 @@
-AUX 0001-Gate-f-string-struct-size-test-for-Rustc-1.76-10371.patch 1232 BLAKE2B e71de8565aa0bc6e23fa48da8b0aa34c633a8613679e2ef72a50542bada2730cc49d15aba1563dd6d6ebe754b3871ff569b8cb85c767e42bb17fe723a3f97fd5 SHA512 b4b20dde59706192fcd382ae7ea93ce05077d47191b2de494f29ec6681fa95d5bd0332af024d33860937ef6541b7adee8bbe6caad5b4bcc73dcda64dc9677cd5
AUX ruff-0.1.14-tests.patch 454 BLAKE2B 0b463b44406811eed53ba0ad41da4807f8865abd4e32e56ac391cad250c1bb22b79a521ed4c7eaed9158f1660d2f15407a001600b68b2f3824376f55ba1e9435 SHA512 873f0a044f0dc662ca9ddd3c1cd0763df735618d965f2c6d849b6622e6ecefceb5495a86dc5bd8dd475473c11f03c0379f5cd910200e0a2637cfaf6e29f7e6c5
AUX ruff-0.2.0-tests.patch 482 BLAKE2B 07ed6b3f416dd43439640f8101fc0fd7272752fc03a60761e1e60d1c99b0ae1efc031565a3cea632a0ba755e4c50bb239e3da827313fd72e8199bc42e536b7dd SHA512 2603c4392cd9055fc23a5bd53d6938b8f8f7ab7fb0e7e9a5201cec86b504d235396da49fddd2ff4d91252e26858738373b9d79d6796ca6db78ff14189a068176
DIST Inflector-0.11.4.crate 17438 BLAKE2B eaf0c7f983b3186e9bc89353021a10592f2877e46585bd50b96db9b087343d1199c7b6cf3fa53cd274fb6d33de025a904b8aa31a7ac9599ae3689ecdbcec34cd SHA512 f1f6463e033b6d3c16c51dc1e1a3f5569954308b95b59058294b7f9310919bbda797e99e6a07529071bb83f0688867a243997d33795a7136b0af73977004296e
diff --git a/dev-util/ruff/files/0001-Gate-f-string-struct-size-test-for-Rustc-1.76-10371.patch b/dev-util/ruff/files/0001-Gate-f-string-struct-size-test-for-Rustc-1.76-10371.patch
deleted file mode 100644
index ea652b5efd04..000000000000
--- a/dev-util/ruff/files/0001-Gate-f-string-struct-size-test-for-Rustc-1.76-10371.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From dbf82233b81b0c3e3aedcb0a26f6c51e66df0797 Mon Sep 17 00:00:00 2001
-From: Charlie Marsh <charlie.r.marsh@gmail.com>
-Date: Tue, 12 Mar 2024 12:46:36 -0700
-Subject: [PATCH] Gate f-string struct size test for Rustc < 1.76 (#10371)
-
-Closes https://github.com/astral-sh/ruff/issues/10319.
-
-Signed-off-by: Eli Schwartz <eschwartz93@gmail.com>
----
- crates/ruff_python_ast/src/nodes.rs | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/crates/ruff_python_ast/src/nodes.rs b/crates/ruff_python_ast/src/nodes.rs
-index 32a3435e7..53cf5b8d8 100644
---- a/crates/ruff_python_ast/src/nodes.rs
-+++ b/crates/ruff_python_ast/src/nodes.rs
-@@ -4148,7 +4148,8 @@ mod tests {
- assert_eq!(std::mem::size_of::<ExprDict>(), 56);
- assert_eq!(std::mem::size_of::<ExprDictComp>(), 48);
- assert_eq!(std::mem::size_of::<ExprEllipsisLiteral>(), 8);
-- assert_eq!(std::mem::size_of::<ExprFString>(), 48);
-+ // 56 for Rustc < 1.76
-+ assert!(matches!(std::mem::size_of::<ExprFString>(), 48 | 56));
- assert_eq!(std::mem::size_of::<ExprGenerator>(), 48);
- assert_eq!(std::mem::size_of::<ExprIf>(), 32);
- assert_eq!(std::mem::size_of::<ExprIpyEscapeCommand>(), 32);
---
-2.43.2
-