summaryrefslogtreecommitdiff
path: root/dev-vcs/blackbox/blackbox-1.20220610.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
commit8b3c41ecef8a1cdd270ce3aabcfdfb991839699c (patch)
treeece43c29d9163f887ef99c43aad6f2f568961231 /dev-vcs/blackbox/blackbox-1.20220610.ebuild
parent1b2360e7bab42e4045232887cb4f6c4a24ca3975 (diff)
gentoo auto-resync : 08:02:2025 - 00:11:30HEADmaster
Diffstat (limited to 'dev-vcs/blackbox/blackbox-1.20220610.ebuild')
-rw-r--r--dev-vcs/blackbox/blackbox-1.20220610.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/blackbox/blackbox-1.20220610.ebuild b/dev-vcs/blackbox/blackbox-1.20220610.ebuild
new file mode 100644
index 000000000000..e019ff7f806a
--- /dev/null
+++ b/dev-vcs/blackbox/blackbox-1.20220610.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Safely store secrets in a VCS repo"
+HOMEPAGE="https://github.com/StackExchange/blackbox"
+SRC_URI="https://github.com/StackExchange/blackbox/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-shells/bash
+"
+
+src_prepare() {
+ default
+
+ # Don't pollute the bin directory with shared scripts.
+ sed -r -i "s:\b(source .*/)(_[^/]+\.sh)\b:\1../share/${PN}/\2:g" bin/* || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/${PN}_*
+ insinto /usr/share/${PN}
+ doins bin/_*.sh
+
+ dodoc AUTHORS {CHANGELOG,DESIGN,README}.md
+ docinto manual
+ dodoc docs/*
+}