summaryrefslogtreecommitdiff
path: root/dev-vcs/bzr/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/bzr/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/bzr/files')
-rw-r--r--dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch33
-rw-r--r--dev-vcs/bzr/files/bzr-2.5.1-sphinx-test-failures.patch24
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch b/dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch
new file mode 100644
index 000000000000..a5128a03d628
--- /dev/null
+++ b/dev-vcs/bzr/files/bzr-2.4.2-no-pyrex-citon.patch
@@ -0,0 +1,33 @@
+--- setup.py.orig 2011-12-26 12:42:40.308882969 +0100
++++ setup.py 2011-12-26 12:43:38.861854988 +0100
+@@ -178,28 +178,8 @@
+ from distutils.errors import CCompilerError, DistutilsPlatformError
+ from distutils.extension import Extension
+ ext_modules = []
+-try:
+- try:
+- from Cython.Distutils import build_ext
+- from Cython.Compiler.Version import version as pyrex_version
+- except ImportError:
+- print("No Cython, trying Pyrex...")
+- from Pyrex.Distutils import build_ext
+- from Pyrex.Compiler.Version import version as pyrex_version
+-except ImportError:
+- have_pyrex = False
+- # try to build the extension from the prior generated source.
+- print("")
+- print("The python package 'Pyrex' is not available."
+- " If the .c files are available,")
+- print("they will be built,"
+- " but modifying the .pyx files will not rebuild them.")
+- print("")
+- from distutils.command.build_ext import build_ext
+-else:
+- have_pyrex = True
+- pyrex_version_info = tuple(map(int, pyrex_version.rstrip("+").split('.')))
+-
++have_pyrex = False
++from distutils.command.build_ext import build_ext
+
+ class build_ext_if_possible(build_ext):
+
diff --git a/dev-vcs/bzr/files/bzr-2.5.1-sphinx-test-failures.patch b/dev-vcs/bzr/files/bzr-2.5.1-sphinx-test-failures.patch
new file mode 100644
index 000000000000..ac1fd0212d6b
--- /dev/null
+++ b/dev-vcs/bzr/files/bzr-2.5.1-sphinx-test-failures.patch
@@ -0,0 +1,24 @@
+Upstream revno 6523 ((vila) Avoid test sphinx-related failures now
+that we don't have direct sphinx anymore. (Vincent Ladeuil))
+
+=== modified file 'bzrlib/tests/test_utextwrap.py'
+--- bzrlib/tests/test_utextwrap.py 2011-05-28 06:44:01 +0000
++++ bzrlib/tests/test_utextwrap.py 2012-04-17 12:18:27 +0000
+@@ -171,16 +171,6 @@
+
+
+ def setup_both(testcase, base_class, reused_class):
+-
+- if (features.sphinx.available()):
+- # Until https://bitbucket.org/birkenfeld/sphinx/issue/706 is fixed,
+- # we can't run these tests when sphinx <= 1.0.1 as it breaks
+- # textwrap.TextWrapper.wordsep_re
+- version = tuple(map(int,
+- features.sphinx.module.__version__.split('.')))
+- if version <= (1, 0, 7):
+- raise tests.TestSkipped(
+- 'sphinx textwrap monkeypatch breaks utextwrap')
+ super(base_class, testcase).setUp()
+ override_textwrap_symbols(testcase)
+ reused_class.setUp(testcase)
+