summaryrefslogtreecommitdiff
path: root/dev-vcs/fossil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/fossil
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/Manifest5
-rw-r--r--dev-vcs/fossil/fossil-2.4.ebuild57
-rw-r--r--dev-vcs/fossil/fossil-2.5.ebuild57
-rw-r--r--dev-vcs/fossil/metadata.xml38
4 files changed, 157 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
new file mode 100644
index 000000000000..24e9a44c3f64
--- /dev/null
+++ b/dev-vcs/fossil/Manifest
@@ -0,0 +1,5 @@
+DIST fossil-src-2.4.tar.gz 4919205 BLAKE2B 35009cffc757b6ea153faf89525cae4463a2169dace090183b9dd6955a615a04363576295e4b24652ebec7f20772ef9d83c6b9af29f68bd5695c56b88cbf77cb SHA512 de7f2321677df7f6dc2a3a20e58f456602d938f40125ef33d401f28cdaa93e38d3db10e109547df269bc95a2ac8669ade05b6fd6fad39e6633f15ffdd91c499f
+DIST fossil-src-2.5.tar.gz 5036719 BLAKE2B b25067ee79793343a017dee28d3ee2b5eb257118a1e334932c6413971f83517ea0cfe570008c35ac4318b52982cb1129ab91eb3380a7f491f09c29cac46a756e SHA512 ee5d8708c91457b7b4d4bada15504e27016a096f0527a81c983c493531d226beb8e4b7aa84b0d764a5404342b8fd2c4dc3196426c9fc8b9c612e1940dd8bde1f
+EBUILD fossil-2.4.ebuild 1488 BLAKE2B 02539210e2eb47e7aecfd9aa0e46a9b9e6061501d3252e997f5ecef94a50fc54b9b8d2e4e96c33c464e92b419fec5bd07938329f044515cedcf4bfae5bc93d69 SHA512 fb5ec8634fc9e147d962840d8000871d42f93edc58a361253ec5e5d287ba2aa59e99d24cc1555f0eb090e02ee0626233a11b357b90c41ef2b8006d2038db88ef
+EBUILD fossil-2.5.ebuild 1537 BLAKE2B 6f1f97c89e738ec97c41090c366f28eafed84459c6465ef80905e1fca8e4a0f62641d1e328a589ae768a02cda42158fe0be2936c1d3d5f0796cd26ef1417618f SHA512 77eace4a15a198040d85e7b2defdfb38f8cb1c4cc37c678911da6c5db0e425c4ad52ac558ac0923dab485ab126d3ea522032d851c52fda842ca29b752b05d8d9
+MISC metadata.xml 1165 BLAKE2B c370f1370c7250945135e56514558acd016742f6d8a9c51e98b9533e094b47dbdc07808abbb1341ad1e987dac6f5f13d2e2f0fef45587935accf082c15227330 SHA512 6ef05c3722bb110e403294b002c253eb1ae4f29a4f5306dccee3abd52ce61c8ae04ed2255f551298d94b8b99d96c799f05bd6df7a9d4e9af08e4c10ce306d0ab
diff --git a/dev-vcs/fossil/fossil-2.4.ebuild b/dev-vcs/fossil/fossil-2.4.ebuild
new file mode 100644
index 000000000000..cd6f4caf4918
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
+ tcl tcl-stubs -tcl-private-stubs th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ system-sqlite? ( >=dev-db/sqlite-3.20.0:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( legacy-mv-rm miniz tcl tcl-stubs tcl-private-stubs
+ th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}
diff --git a/dev-vcs/fossil/fossil-2.5.ebuild b/dev-vcs/fossil/fossil-2.5.ebuild
new file mode 100644
index 000000000000..dbba71f4ebb5
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
+ tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ system-sqlite? ( >=dev-db/sqlite-3.22.0:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
+ th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}
diff --git a/dev-vcs/fossil/metadata.xml b/dev-vcs/fossil/metadata.xml
new file mode 100644
index 000000000000..5f61527e696f
--- /dev/null
+++ b/dev-vcs/fossil/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <use>
+ <flag name="fusefs">Enable the Fuse Filesystem</flag>
+ <flag name="json">Enable the JSON API of Fossil's wiki</flag>
+ <flag name="legacy-mv-rm">
+ Enable legacy behavior for mv/rm (skip checkout files).
+ </flag>
+ <flag name="miniz">
+ Use the bundled miniz for compression instead of
+ zlib. Incompatible with ssl.
+ </flag>
+ <flag name="system-sqlite">
+ Use the system SQLite instead of the bundled one
+ </flag>
+ <flag name="tcl-stubs">
+ Enable Tcl integration via stubs library mechanism
+ </flag>
+ <flag name="tcl-private-stubs">
+ Enable Tcl integration via private stubs mechanism
+ </flag>
+ <flag name="th1-docs">
+ Enable TH1 for embedded documentation pages
+ </flag>
+ <flag name="th1-hooks">
+ Enable TH1 hooks for commands and web pages
+ </flag>
+ </use>
+</pkgmetadata>