summaryrefslogtreecommitdiff
path: root/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild')
-rw-r--r--dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild b/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
new file mode 100644
index 000000000000..44eacb2a7a3e
--- /dev/null
+++ b/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE='sqlite'
+
+inherit python-single-r1
+
+DESCRIPTION="Bugzilla subcommand for git"
+HOMEPAGE="http://www.fishsoup.net/software/git-bz/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ ${PYTHON_DEPS}"
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED%/}"/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/pycrypto; then
+ elog "For Chrome/-ium cookie decryption support, please install:"
+ elog " dev-python/pycrypto"
+ fi
+}