summaryrefslogtreecommitdiff
path: root/dev-vcs/git-deps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/git-deps
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/git-deps')
-rw-r--r--dev-vcs/git-deps/Manifest3
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild47
-rw-r--r--dev-vcs/git-deps/metadata.xml15
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-vcs/git-deps/Manifest b/dev-vcs/git-deps/Manifest
new file mode 100644
index 000000000000..bb6bb5fa6f6b
--- /dev/null
+++ b/dev-vcs/git-deps/Manifest
@@ -0,0 +1,3 @@
+EBUILD git-deps-9999.ebuild 1028 SHA256 f1aa57a572b23baa147eacea52956931e02fff80f15f7bae5b05f6d0d04dab9f SHA512 2e8826945a6840739f83a266e388fd79ced5394a501d322113e80260711cc1b493d1a060d30b21ca9f967a1651cdd1fcb239a6a390e48488b62c69db6f7e655c WHIRLPOOL 442012e7d4cdff46d6a25b8b8570739a0d8621b7db7fd1984d9d3d83a402c00f54987e9b607f14fa98a5971d9cd50a9a312a1f4f168225b647a60470d6c24c76
+MISC ChangeLog 1547 SHA256 ede9f74b537c8f6deea66dc88b268358dcf021d2dfb0c31423ff2c281c72e0ba SHA512 7fed283c60d3c3b991d2fefb0c2464011c626adbad4c8b3478877a22f990e27a50379b1de1018fad4a0a2686b9f3227380f01ce83d76ec33000f8e7aea7313a7 WHIRLPOOL 4ca037623310a22e694c38a17aa74f955099d9b85a632d22075d0451a0ae10c600dad09a4a29837c00028bbadb8969eb9d030748f295733bf83a8a0d17d66e9b
+MISC metadata.xml 490 SHA256 309bd550e724f187f91a7eae37a24315f6c524da0b625945d69b7746f677c2bb SHA512 005daa7d1c3abffad1bda794339947dabfdb097a2abe85a1ea5b85fd962332d788d2903301f2b3442a3f35f5b97eb25d3ddd1add00460108ffc857f57c3fa926 WHIRLPOOL 46a4363215789d19a7bce79b9b1aab5ce9a3f78cf5dfb33bd562f338b5dfeb79503ab9b5c3b29703ab064be27e94b6960b3cf47a8b0a9670b08f72ad6e73b1f0
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
new file mode 100644
index 000000000000..f66f91356572
--- /dev/null
+++ b/dev-vcs/git-deps/git-deps-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/aspiers/git-deps"
+EGIT_BRANCH=master
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils git-r3 python-single-r1
+
+DESCRIPTION="git commit dependency analysis tool"
+HOMEPAGE="https://github.com/aspiers/git-deps"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygit2[${PYTHON_USEDEP}]
+ net-libs/nodejs
+ ${PYTHON_DEPS}
+ "
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+HTML_DOCS="html/."
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ python_newscript git-deps.py git-deps
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Notes regarding the '--serve' option:"
+ elog "Please run 'npm install browserify' once"
+ elog "Copy the html sources:"
+ elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
+ elog "cd ~/git-deps-html"
+ elog "npm install"
+ elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
+}
diff --git a/dev-vcs/git-deps/metadata.xml b/dev-vcs/git-deps/metadata.xml
new file mode 100644
index 000000000000..1a9f54bc290b
--- /dev/null
+++ b/dev-vcs/git-deps/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ git-deps is a tool for performing automatic analysis of dependencies
+ between commits in a git repository.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aspiers/git-deps</remote-id>
+ </upstream>
+</pkgmetadata>