summaryrefslogtreecommitdiff
path: root/dev-vcs/git-remote-hg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/git-remote-hg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-remote-hg')
-rw-r--r--dev-vcs/git-remote-hg/Manifest5
-rw-r--r--dev-vcs/git-remote-hg/git-remote-hg-0.2.ebuild24
-rw-r--r--dev-vcs/git-remote-hg/git-remote-hg-0.3.ebuild27
-rw-r--r--dev-vcs/git-remote-hg/metadata.xml16
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-vcs/git-remote-hg/Manifest b/dev-vcs/git-remote-hg/Manifest
new file mode 100644
index 000000000000..2c2b43d8dd00
--- /dev/null
+++ b/dev-vcs/git-remote-hg/Manifest
@@ -0,0 +1,5 @@
+DIST git-remote-hg-0.2.tar.gz 30397 BLAKE2B 9c96c420a9e38fb3e0a223f12343834abdb742d15140330b1f5a12b68da924466106a279802a525c085c176d706cce427e73b1f86eeb99a6a413ab6de5954b18 SHA512 eb08a90b786593602510fef6210bb381a605d6c4cfda7e0c1051162d0a9929c077081f530dcdfb95f6fd8f0114ed44ea2c8f267e0e7ac110f9445941c9dd8546
+DIST git-remote-hg-0.3.tar.gz 30995 BLAKE2B c65918a985459149df85b1519f4d4b15be53c26d28a32cb660d85fa386a488668e2d042c7687fd4ea0928237d3098d5d3bcd77f8a0e78742b530b7cc2dff1195 SHA512 33ff1874909c0ce4d8b44d1dfd6ae706df44b36ead566e09be0f4e94e3b2a5c8603bd2f2fd50e8faa99d6aeb44a7792d7118c4413f8c9a8b8c29108b534bb4f4
+EBUILD git-remote-hg-0.2.ebuild 533 BLAKE2B 2bc0641461db8c97947e64d4990e6d1672327b149b1b653777881f8c251df7ef093e2aef901f790b46c0a237efd303c49edfb3686be9f4926de46e37bfc5419b SHA512 e0ae87af402526dac263d36c5b13faa7fbac95fe7b2d897502086f010ff2c14c146800de0d51392ac60ebe2dc4a3ba74033ce166b062bd9ba2d6b46dd4d34b9c
+EBUILD git-remote-hg-0.3.ebuild 576 BLAKE2B a82d541d1c4d58f8a67d9c7902876a964eaf0dde80bca5c9ba59770b31fe79dec635ba4379a749ed27323fcd03df3000b59c183978381b07b12e94ee19994846 SHA512 369c2d2be9efb854b1564b0268b8959563a32cd372150e0c6b430e1db5bf3124a0fa84e8dd97153bdf3e9d12fc977f1ca88f9b91c4b1e8a79a9f69a0ec8555d2
+MISC metadata.xml 570 BLAKE2B de338749634d4141b4c73fe511c6b2097edd36ed633cb58ef1c9e6ddb237876d4a55f1423e2d6c04805de38b133f700a2784268dc3926cc731ccc5c8bb256a77 SHA512 07bfa78ad5d7558a6c3607e4b5dfcd2908d9227acedd4393c7a0002fed383dc85a68f6758b2013b83a6f810188c99952e7718d987f1cfddfd710f5a135ccf3d5
diff --git a/dev-vcs/git-remote-hg/git-remote-hg-0.2.ebuild b/dev-vcs/git-remote-hg/git-remote-hg-0.2.ebuild
new file mode 100644
index 000000000000..297bee0751bb
--- /dev/null
+++ b/dev-vcs/git-remote-hg/git-remote-hg-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=(python2_7)
+
+DESCRIPTION="Semi-official Mercurial bridge from Git project"
+HOMEPAGE="https://github.com/felipec/git-remote-hg"
+SRC_URI="https://github.com/felipec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-vcs/git
+ dev-vcs/mercurial"
+RDEPEND="${DEPEND}"
+
+# Most (21/25) tests fail:
+RESTRICT="test"
+
+src_install() {
+ dobin git-remote-hg
+}
diff --git a/dev-vcs/git-remote-hg/git-remote-hg-0.3.ebuild b/dev-vcs/git-remote-hg/git-remote-hg-0.3.ebuild
new file mode 100644
index 000000000000..3d5b16b08b94
--- /dev/null
+++ b/dev-vcs/git-remote-hg/git-remote-hg-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=(python2_7)
+
+DESCRIPTION="Semi-official Mercurial bridge from Git project"
+HOMEPAGE="https://github.com/felipec/git-remote-hg"
+SRC_URI="https://github.com/felipec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-vcs/git
+ dev-vcs/mercurial"
+
+DEPEND="${CDEPEND}
+ app-text/asciidoc"
+RDEPEND="${CDEPEND}"
+
+# Most (21/25) tests fail:
+RESTRICT="test"
+
+src_install() {
+ dobin git-remote-hg
+}
diff --git a/dev-vcs/git-remote-hg/metadata.xml b/dev-vcs/git-remote-hg/metadata.xml
new file mode 100644
index 000000000000..0fe237632666
--- /dev/null
+++ b/dev-vcs/git-remote-hg/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <longdescription>
+ 'git-remote-hg' is the semi-official Mercurial bridge from Git project,
+ once installed, it allows you to clone, fetch and push to and from
+ Mercurial repositories as if they were Git ones.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">felipec/git-remote-hg</remote-id>
+ </upstream>
+</pkgmetadata>