summaryrefslogtreecommitdiff
path: root/dev-vcs/git-spindle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/git-spindle
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/git-spindle')
-rw-r--r--dev-vcs/git-spindle/Manifest5
-rw-r--r--dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild29
-rw-r--r--dev-vcs/git-spindle/git-spindle-3.3.ebuild26
-rw-r--r--dev-vcs/git-spindle/metadata.xml17
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-vcs/git-spindle/Manifest b/dev-vcs/git-spindle/Manifest
new file mode 100644
index 000000000000..ace53812aa62
--- /dev/null
+++ b/dev-vcs/git-spindle/Manifest
@@ -0,0 +1,5 @@
+DIST git-spindle-3.3.tar.gz 1854895 SHA256 4bfad8e716e16e267c1297bb66b563a5eb4a3f90d618338442529a9c773bd4d1 SHA512 5d56f51d952ccfea321be79108a795d9e7dd7eca78d966955e76e1c8297eafc9899ef40b6ef1bfff692fe0ce7c3d54ead0ff5fdf31eb559d3ebc0ef9de91c3e8 WHIRLPOOL dc3286136e08a9a75764183f780834d9dfe7bfd7c49d7e97084405399c7e02bcb3402b71672b5dc3b439b6f64fe8732c8e459a4884bbe1aabaa2ae99c5c98166
+EBUILD git-spindle-3.3-r1.ebuild 686 SHA256 06a8745ffef8f2744c0267046becc4105874bcadb1c2eb9b927ce5f1109dde12 SHA512 0de494858b2e9aee4fdb66fa15badd9cf96801527afcfb98921bc8eb6d1385af8a4e787ba03a393c933fc5566608358efdb31937db6c168e7e7134ca340035e2 WHIRLPOOL 587db669853c8e21c3ccaf777eee65506b929e7629c76f7adcc3ed86bb02a69f72004acfcdc4bb7e0dc13d1e6211e53800a59dbfa436a8b0997971a92409a856
+EBUILD git-spindle-3.3.ebuild 567 SHA256 bd0c11b1d71198180a6dd65476776b7a0e307b7ba8570ec6ba723dd2867fb35b SHA512 1cf7e0fa874fd14e8dac447d1ec5a7cf58479476ea1b63d7ae379c4ea0ed80d9e972898a49e7a08508d5ef3359911e0d57a86feebbba65cec9299d4889198aa6 WHIRLPOOL cbe9969c1d3281353ab84ec1c5563c1c2dbeef27b1e09afe127dc27616039394719a072a32cf7b10d5df8167a212ff77ded0303e937bbe564438c748e9a1b24e
+MISC ChangeLog 454 SHA256 55ebef00ccd165a57f8159887bcf6f8c79d25d4ac7ab8318bd87329bd3039729 SHA512 94d2f3afa1d2c70361b7980861b793047baa99be592e0c74b1e216bdd3aa1aa68b5dc2d3f2d54bdc11065dad89c956b9c32483e86b1a45ddb4dbabe475f67859 WHIRLPOOL 9ba2f5039d1aea52136759f17b3db652809074b8bd09739f4a89ce28965fbb872e0289985cc73be785b47a1e7e7d4e5752caccacabf4ad63cbc6c0603ccf5ec4
+MISC metadata.xml 626 SHA256 2955a445620507fba108530526c09f04a6d965cf0ae6c702189b5688a004a6c7 SHA512 7f2be03b228a372aeb1a17913d790ec69c2d02d684c9495c460fff28b00b4a36e14b66e25e0ed31f0c9c0913ff5292cff02ca690308fe3feee84b66e9b3678b6 WHIRLPOOL de606d8d7df13e6820af8bec27f35d3d6bd32cb4bbaed6c4cb034767d07863a8a3573092559097de073baf555834ecc59034afc3b73babae71f74f959ed8e914
diff --git a/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild b/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
new file mode 100644
index 000000000000..7d970a8cd2ff
--- /dev/null
+++ b/dev-vcs/git-spindle/git-spindle-3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Git subcommands for interacting with central services"
+HOMEPAGE="http://seveas.github.io/git-spindle/"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ dev-python/github3[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/whelk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-vcs/git-spindle/git-spindle-3.3.ebuild b/dev-vcs/git-spindle/git-spindle-3.3.ebuild
new file mode 100644
index 000000000000..9ebebd0d3a0b
--- /dev/null
+++ b/dev-vcs/git-spindle/git-spindle-3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Git subcommands for interacting with central services"
+HOMEPAGE="http://seveas.github.io/git-spindle/"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-vcs/git
+ ${PYTHON_DEPS}"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-vcs/git-spindle/metadata.xml b/dev-vcs/git-spindle/metadata.xml
new file mode 100644
index 000000000000..baa38de52430
--- /dev/null
+++ b/dev-vcs/git-spindle/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Nicolas Bock</name>
+ <email>nicolasbock@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Many central git hosting services, such as GitHub and GitLab, provide
+ an API to perform actions such as creating repositories and filing
+ pull requests. git-spindle is a collection of git subcommands to make
+ using these services easier.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">seveas/git-spindle</remote-id>
+ </upstream>
+</pkgmetadata>