summaryrefslogtreecommitdiff
path: root/dev-vcs/guilt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-vcs/guilt
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-vcs/guilt')
-rw-r--r--dev-vcs/guilt/Manifest2
-rw-r--r--dev-vcs/guilt/files/guilt-0.36-fix-help.patch41
-rw-r--r--dev-vcs/guilt/guilt-0.36-r1.ebuild53
3 files changed, 96 insertions, 0 deletions
diff --git a/dev-vcs/guilt/Manifest b/dev-vcs/guilt/Manifest
index 10b7b19397e9..06f21add9946 100644
--- a/dev-vcs/guilt/Manifest
+++ b/dev-vcs/guilt/Manifest
@@ -1,3 +1,5 @@
+AUX guilt-0.36-fix-help.patch 1192 BLAKE2B 1e2802baf7aad902f180a8b477cf163c383cd59033dbe6863f3d8dc83a34effdeb46f6e800fd377605bb4d6f295dcf63dac765eee0ec8315b5a7b8e497b5f447 SHA512 2dcb6db0ee356b1cf4366a25f82abf6c9170b424fe3884d7b3259b6363afb9966c0e33b6b8bf5707feb229dc75f0555b02506ff7b26a8ec3ead206e6fdc8bd6c
DIST guilt-0.36.tar.gz 64624 BLAKE2B 8514f0fa6c7dd96e3a8c90939046b45b2e3115f2361a428ad58e1c67db0cc73cab1304a1493a45b1fda2928cc8a03b03e2986c845c826bcd7b491d264d3d1333 SHA512 882438d5b9ed4d16e3dfc95ddbef6ec1d76860d82aa6abc78010351577fb65578f919c6fe55f9d7593c82b0eae2d0dd80d577eee906fff84a426391936242652
+EBUILD guilt-0.36-r1.ebuild 1268 BLAKE2B 1f6638707e01445d6f6f65f2f886f1c47d0014d6c334ae4ba6c52efcb531f538a7868b3a52e8f39b2a0c5ac914e4fd164d1ad43d518bfd75b46d3dd173c05791 SHA512 2a60e039768800872b8314f8631518d0cb06d2c5a8db6b3529703af382804f71949ae5360fefc390c91a2ce6a7f7b4879e73f9d6bb05fc63b9c9997a7cd7eede
EBUILD guilt-0.36.ebuild 1224 BLAKE2B f00929b77ab0b0a48f2f965bc763bcef45ab60d703ea1e6f93204b3befb80f31c7b4b723ee1a564a5da028de405d74dfc899a055a3b2339f13c6dea681081576 SHA512 de51109ca240eed4c23d98fccc088faa4151b7e8064dafdffa9ddc528397c90b0692a02a090703b44ec8a0579d4eda13eedf39ccbeacc8f1c68058aa6f2a2aff
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-vcs/guilt/files/guilt-0.36-fix-help.patch b/dev-vcs/guilt/files/guilt-0.36-fix-help.patch
new file mode 100644
index 000000000000..31e81bdb90e2
--- /dev/null
+++ b/dev-vcs/guilt/files/guilt-0.36-fix-help.patch
@@ -0,0 +1,41 @@
+From 53db96dd0c37b2fd299a26a00ba9b6f53cf6224e Mon Sep 17 00:00:00 2001
+Date: Thu, 28 Dec 2017 20:01:08 -0500
+Subject: [PATCH] Fix broken guilt help system
+
+ https://bugs.gentoo.org/642584
+---
+ guilt | 4 ++--
+ guilt-help | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/guilt b/guilt
+index 35177b9..498dfb6 100755
+--- a/guilt
++++ b/guilt
+@@ -73,8 +73,8 @@ GUILT_PATH="$(dirname "$0")"
+
+ guilt_commands()
+ {
+- find "$GUILT_PATH/../lib/guilt" -maxdepth 1 -name "guilt-*" -type f -perm +111 2> /dev/null | sed -e "s/.*\\/$GUILT-//"
+- find "$GUILT_PATH" -maxdepth 1 -name "guilt-*" -type f -perm +111 | sed -e "s/.*\\/$GUILT-//"
++ find "$GUILT_PATH/../lib/guilt" -maxdepth 1 -name "guilt-*" -type f -executable 2> /dev/null | sed -e "s/.*\\/$GUILT-//"
++ find "$GUILT_PATH" -maxdepth 1 -name "guilt-*" -type f -executable | sed -e "s/.*\\/$GUILT-//"
+ }
+
+ # by default, we shouldn't fail
+diff --git a/guilt-help b/guilt-help
+index 93442a3..b29e059 100755
+--- a/guilt-help
++++ b/guilt-help
+@@ -34,7 +34,7 @@ case $# in
+ ;;
+ esac
+
+-MANDIR=`dirname $0`/../man
++MANDIR=`dirname $0`/../share/man
+ MANDIR=`(cd "$MANDIR"; pwd)`
+ exec man -M "$MANDIR" "$page"
+
+--
+2.13.5
+
diff --git a/dev-vcs/guilt/guilt-0.36-r1.ebuild b/dev-vcs/guilt/guilt-0.36-r1.ebuild
new file mode 100644
index 000000000000..ab2b064429e9
--- /dev/null
+++ b/dev-vcs/guilt/guilt-0.36-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A series of bash scripts which add a quilt-like interface to git"
+HOMEPAGE="http://repo.or.cz/w/guilt.git"
+SRC_URI="${HOMEPAGE}/snapshot/22d785dd24329170f66e7696da38b3e90e033d61.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# Since we need to build the man pages anyway, I don't think it makes
+# much sense to hide the HTML docs behind USE=doc.
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-22d785d"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${P}-fix-help.patch
+
+ # The doc makefile tries to shell out to `git` for the version.
+ sed -i Documentation/Makefile \
+ -e "s/VERSION=.*/VERSION=${PV}/" \
+ || die 'failed to set VERSION in Documentation/Makefile'
+}
+
+src_compile() {
+ emake -C Documentation all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc Documentation/{Contributing,Features,HOWTO,Requirements}
+ emake -C Documentation \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ mandir=/usr/share/man \
+ htmldir="/usr/share/doc/${PF}/html" \
+ install install-html
+}