summaryrefslogtreecommitdiff
path: root/dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild')
-rw-r--r--dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild b/dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild
new file mode 100644
index 000000000000..8bcc76377839
--- /dev/null
+++ b/dev-vcs/hg-evolve/hg-evolve-10.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx
+ media-gfx/imagemagick[svg]
+ )"
+
+python_prepare_all() {
+ rm hgext3rd/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r html/
+ fi
+}