summaryrefslogtreecommitdiff
path: root/dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild')
-rw-r--r--dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild b/dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild
new file mode 100644
index 000000000000..4f1db8db068d
--- /dev/null
+++ b/dev-vcs/hg-evolve/hg-evolve-9.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_prepare_all() {
+ rm hgext3rd/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r html/
+ fi
+}