summaryrefslogtreecommitdiff
path: root/dev-vcs/pre-commit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-01 19:28:40 +0000
commitd628c1f8493d09e3deb5d19971cd21691d8758e4 (patch)
tree7afecb9f9148ecf631ac2093143278e041cc5acd /dev-vcs/pre-commit
parent4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (diff)
gentoo auto-resync : 01:03:2025 - 19:28:40
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.8.0-r1.ebuild76
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index d05f9a97f164..c37691730c4f 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,8 +1,6 @@
AUX pre-commit-3.1.1-tests_git_file_transport.patch 1527 BLAKE2B 18d047f3b8a6fdc3da77aa5b8d9f60970ab5b69adc3790489ceffc17839a4cd21ed46428c5e2e98b50278b2c4dc49e35a09dd778000546828327ae96f910f95b SHA512 36cb194250dc0fefad2900452447ab590f678e6cd5edf07a7f072363733c263b7cb1167297c465a9372d4a38ab77a6c057046c66b872a958132a97d1a937d029
-DIST pre-commit-3.8.0.gh.tar.gz 270925 BLAKE2B febb7b6bb2e43aec096e454b064b01b0973cd9d04b2d792a4ce7cef9df4f9c9c2e3bf1200f584e163c829c12ca17f57761375b297ab5c3d97dce569d5c219bdd SHA512 b6970ac00c5033938462675c20ea5e13c0439dc4f70cd627f11b22b0f87fb0a3590e9b3e9c677bfb66e4b3420f40de66ca7ccbc969847ee5fa8994532a558cd1
DIST pre-commit-4.0.1.gh.tar.gz 286821 BLAKE2B 2d38ef4ad06744e11a75a9faddcf90f1fbb60f597d85782bf8065e90e746e62de0f7396ad09e3d03502208114ed75ed57f05ae143470b349a9b1dd6860ba72bd SHA512 93c01e4d64aa1010bdaac6e1774497fe38f757cc6b67b7546332c5fe3846583fc5ac71f70bb257e5bbe24062e060307b49abdcb539538ccedeb2cdf2243908a4
DIST pre-commit-4.1.0.gh.tar.gz 289203 BLAKE2B 8a3264dcbc01f6a7544b7f8425f320e701eb8aad63a4be9843bec5c95cda3bc47a8458b94967eaf4fad5d24c5b86062c999de0e482386293d6562aa5b4244631 SHA512 d10f90da9c8b2130cd6c17d337787648fb28774e5b4df4017cd57264530dca87b03a07e549b46cc2e5c8f292c34c0890c4940f03ed132a7a274176c45f387607
-EBUILD pre-commit-3.8.0-r1.ebuild 2132 BLAKE2B 5bda58bacf4e98a4328db604a058e70399ed91ad4413f40a849149931eafd28005b5bf944aff4205ecda081e65b6ee5370faf5a9bebf88e3bcd45d13b9b28c74 SHA512 7ea6a4c5d5a21f485d8cf06269d7ef591b97771650c92be31cfb7388852020f461f7ce2d09af5d6465366e790de9dcb15f19ba74dd08b049243cae488b98d65e
EBUILD pre-commit-4.0.1.ebuild 2132 BLAKE2B c233a203b615392a7353dff694a688cbda116c59682436e57e7abb5265c0b7069ab34514e8aa1bf6d2fc772fc5107da3161ad433f57c39e9aa1d64bd55ead82b SHA512 3070bde4aa45c6150caee6a26ddc80e8480745ce3948165606d7f643627df43fb5db8e87e6c7ae71f5380f0f966c5d9902ab346c25460ed0443724e92f69d7a4
EBUILD pre-commit-4.1.0.ebuild 2134 BLAKE2B f8162246bdf41b1048c8aa011bff1bdce3cd2bf3237c4598ba457b022314c8214555f57a3ad8265e530c378ebbda8539dff0549d2008ae047a72175f0bc14959 SHA512 04316936c870e305de31cd297c378ae1d3073a4fbd6e9bd2bcfa998e3bde930563222335f61f7262c908c4aaa1351363b53ebffcd8c2f36a5a7d6b21c0fac0f8
MISC metadata.xml 391 BLAKE2B 08aea5db96326e51f252d2392f655100d2721dfa8eedfbb361221d92b0b0e0645152b8e1c2ccc11e8b50f24b59869fa2e1fc7dfaa42fdb23614ddbc963e9f102 SHA512 799e0df03afd4baef6296590b9133b45487d1e41f09e933a738367f0bcb3c6510ec8e26547b16ea5c07525d99b026ba1848d21e4001505c33a564b14746897c6
diff --git a/dev-vcs/pre-commit/pre-commit-3.8.0-r1.ebuild b/dev-vcs/pre-commit/pre-commit-3.8.0-r1.ebuild
deleted file mode 100644
index 5de721b64f53..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.8.0-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-PYTHON_REQ_USE="sqlite"
-DISTUTILS_SINGLE_IMPL="ON"
-DISTUTILS_USE_PEP517="setuptools"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/
- https://github.com/pre-commit/pre-commit/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
- KEYWORDS="amd64 ~arm64 ~hppa ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')
-"
-# coreutils requirement, see bug #885559
-BDEPEND="
- sys-apps/coreutils[-multicall]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-3.1.1-tests_git_file_transport.patch" )
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-EPYTEST_DESELECT=(
- # All of these require a boatload of dependencies (e.g. Conda, Go, R and
- # more) in order to run and while some of them do include
- # "skip if not found" logic, most of them do not.
- tests/languages/
- tests/repository_test.py
-
- # These three consistently fail with
- # Calling "git rev-parse" fails with "fatal:
- # not a git repository (or any of the parent directories): .git".
- # including with the sandbox disabled.
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_hook_stage_migration
- tests/main_test.py::test_try_repo
-
- # These two fail if pre-commit is already installed (Bug #894502)
- tests/commands/install_uninstall_test.py::test_environment_not_sourced
- tests/commands/install_uninstall_test.py::test_installed_from_venv
-)
-
-distutils_enable_tests pytest