summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
commite0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (patch)
tree7a71d24a0bfba0874deeb5e8131d579dfb40e1d1 /dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
parent7cffc3e7845d1a3ae331145c5e1226e314badf4a (diff)
gentoo auto-resync : 15:07:2022 - 01:41:14
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
new file mode 100644
index 000000000000..85ac20d563aa
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+BDEPEND="test? (
+dev-python/coverage[${PYTHON_USEDEP}]
+>=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
+dev-python/pytest-cov[${PYTHON_USEDEP}]
+>=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}