summaryrefslogtreecommitdiff
path: root/dev-vcs/stagit/stagit-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
commit3fd9d065ab109700e92fc1cea2a6519a39a5b007 (patch)
tree2666118c9404e846180636fbd2de92e3bd7870fd /dev-vcs/stagit/stagit-1.2.ebuild
parent11c791ab62dc711840a52676eef212362840fc17 (diff)
gentoo auto-resync : 09:08:2022 - 02:15:09
Diffstat (limited to 'dev-vcs/stagit/stagit-1.2.ebuild')
-rw-r--r--dev-vcs/stagit/stagit-1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/stagit/stagit-1.2.ebuild b/dev-vcs/stagit/stagit-1.2.ebuild
new file mode 100644
index 000000000000..c820b61e2951
--- /dev/null
+++ b/dev-vcs/stagit/stagit-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Generates static HTML pages for a Git repository"
+HOMEPAGE="https://codemadness.org/stagit.html"
+SRC_URI="https://codemadness.org/releases/stagit/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/libgit2:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1-pkg-config.patch )
+
+src_install() {
+ emake DESTDIR="${D}" \
+ DOCPREFIX="${EPREFIX}"/usr/share/doc/${PF} \
+ MANPREFIX="${EPREFIX}"/usr/share/man \
+ PREFIX="${EPREFIX}"/usr \
+ install
+}