summaryrefslogtreecommitdiff
path: root/dev-vcs/stgit/stgit-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 00:29:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 00:29:05 +0000
commit467e2131896a3030032cd5b0fab2094a045bf9d0 (patch)
tree534578ca7ef61b3eb30fee861db78c0ae58e2fa6 /dev-vcs/stgit/stgit-2.1.0.ebuild
parent1f254b1ee917690b4f8f7738fdcfc295ee304ff7 (diff)
gentoo auto-resync : 18:03:2023 - 00:29:05
Diffstat (limited to 'dev-vcs/stgit/stgit-2.1.0.ebuild')
-rw-r--r--dev-vcs/stgit/stgit-2.1.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-vcs/stgit/stgit-2.1.0.ebuild b/dev-vcs/stgit/stgit-2.1.0.ebuild
index bb5b17a5eeb7..20fc837b2e4e 100644
--- a/dev-vcs/stgit/stgit-2.1.0.ebuild
+++ b/dev-vcs/stgit/stgit-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Auto-Generated by cargo-ebuild 0.5.2
@@ -123,7 +123,7 @@ CRATES="
xattr-0.2.3
"
-inherit cargo
+inherit cargo flag-o-matic
DESCRIPTION="Manage a stack of patches using GIT as a backend"
HOMEPAGE="https://stacked-git.github.io"
@@ -140,6 +140,14 @@ IUSE="doc"
DEPEND="doc? ( app-text/asciidoc )"
RDEPEND=""
+# rust does not use *FLAGS from make.conf, silence portage warning
+# update with proper path to binaries this crate installs, omit leading /
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_configure() {
+ filter-lto #bug 897692
+}
+
src_compile() {
cargo_src_compile
emake completion