summaryrefslogtreecommitdiff
path: root/dev-vcs/stgit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-vcs/stgit
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-vcs/stgit')
-rw-r--r--dev-vcs/stgit/Manifest4
-rw-r--r--dev-vcs/stgit/stgit-1.4.ebuild2
-rw-r--r--dev-vcs/stgit/stgit-1.5.ebuild78
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 7176c5d22194..07663e7914bf 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,3 +1,5 @@
DIST stgit-1.4.tar.gz 390734 BLAKE2B a2c8b6848cacd743022318ebf9a0512c6bd02a2b8c864db2270e5075c82dfd9e6037a3a79978b2061487bf040864077b0f7836c66986d82ff3eb902331589d87 SHA512 5251dc26a7c64dcc83021399f95ea911d6b65cfb2ee5c016c886447740ed48b66d3f0bd92a45b4aed40ae2e77dfe6ba62336dbba6773a1879ab749c95bb99b4b
-EBUILD stgit-1.4.ebuild 1814 BLAKE2B 40c7993866ef309dfd3e4d517de07d9cc525dc9b3658793dc2b446b7a59907e2161c725bad71d0df6015bd9da180a288b1b0e98b04438d0b58701648c0473341 SHA512 4b4fb8363a90b2b2c5e412fb623d6cc8bad86dac113f3895ae509f9cdecf63f11e16de32eb49dcdc076c1ad0f7927db77413b9843159e87ad4dc577ce0a7e85d
+DIST stgit-1.5.tar.gz 398562 BLAKE2B 922e014dcd0976a6b9ac884faa5ac6d8cb0e9efe6c56201c85675afb041e0190d07fb3cbcd366664b736d428d93188fc92c19db9a8d1fdc322054e1480b5b8f8 SHA512 6f018754f43c3ba48ce381b59f0e4033c295f0bd0acee4d07c1457f2c004caee9d8e9f6b2af1ee0d46941777639c7f5a49caa4c0dd01a72c3f3a43a34bf9b2bf
+EBUILD stgit-1.4.ebuild 1813 BLAKE2B 1505ba0218afe136851c24864fac25f85495b0a8bc2bf6e0dcec665f53e50def7a1e24ebe054e0d0b1da909ce18b0b164231e59766b2db74e062d8853ff2bc17 SHA512 cd838bcab5e06caaf2aa08fd03dbab09af2c26cb74f1aee9ecaee3de28daaa8213788da8b0f1431ef4d497075292e7b91cff3c716081867287f422656faaf645
+EBUILD stgit-1.5.ebuild 1819 BLAKE2B 097322735d473fce8c5cba1f247ba5b72d7949ea84702fb10e60baa10906f4fd86fdcc5a07fd7cd3075b665251ed5cc71890d2d82b226bf77e412e590b39b569 SHA512 bac4f938dfb1d4702d1ea0eb5d9a1a844696186e92f5d31cdf41433fc06594f8a2f5c949d8f3a2a53b988d6b69407c0260c7606f893e91a7fe992e577cd9a318
MISC metadata.xml 347 BLAKE2B 152f011c7facd06cc1c654f388b4a44bbd8486549c07f1329d228e252a411bfb565e4f5b9e37bf9eefc23fda47a774c347d2e82070ac21c0880806bca99a6685 SHA512 04b087c0e6c6ae99128dab9c29e49d55e1cbcac3890f6324d3ea66b14530e92ca9ed32e9a6dfa23f06e23f8b79b3e57ceff2c9cc2995af4e01c91914d50361d0
diff --git a/dev-vcs/stgit/stgit-1.4.ebuild b/dev-vcs/stgit/stgit-1.4.ebuild
index ffb9c6761f48..27a2b51f5133 100644
--- a/dev-vcs/stgit/stgit-1.4.ebuild
+++ b/dev-vcs/stgit/stgit-1.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1
diff --git a/dev-vcs/stgit/stgit-1.5.ebuild b/dev-vcs/stgit/stgit-1.5.ebuild
new file mode 100644
index 000000000000..23c4d6bccb08
--- /dev/null
+++ b/dev-vcs/stgit/stgit-1.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="https://stacked-git.github.io"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp completion/stgit.bash 'stg'
+}