summaryrefslogtreecommitdiff
path: root/dev-vcs/svn2cl/svn2cl-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/svn2cl/svn2cl-0.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/svn2cl/svn2cl-0.12.ebuild')
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.12.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/svn2cl/svn2cl-0.12.ebuild b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
new file mode 100644
index 000000000000..d7a60b4d0f3f
--- /dev/null
+++ b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-vcs/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the wrapper script looks for the xsl files in the
+ # same directory as the script.
+ epatch "${FILESDIR}"/0.9-wrapper.patch
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl || die
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
+ doman svn2cl.1 || die
+}
+
+pkg_postinst() {
+ einfo "You can find samples of svn2html.css and authors.xml in"
+ einfo "/usr/share/doc/${PF}/"
+ einfo "Read man page for details."
+}