summaryrefslogtreecommitdiff
path: root/dev-vcs/svn2cl/svn2cl-0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-vcs/svn2cl/svn2cl-0.14.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-vcs/svn2cl/svn2cl-0.14.ebuild')
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/svn2cl/svn2cl-0.14.ebuild b/dev-vcs/svn2cl/svn2cl-0.14.ebuild
new file mode 100644
index 000000000000..e9516274cee7
--- /dev/null
+++ b/dev-vcs/svn2cl/svn2cl-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
+HOMEPAGE="https://arthurdejong.org/svn2cl/"
+SRC_URI="https://arthurdejong.org/svn2cl/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+
+RDEPEND="dev-libs/libxslt
+ dev-vcs/subversion"
+
+PATCHES=( "${FILESDIR}/0.9-wrapper.patch" )
+
+src_install() {
+ newbin svn2cl.sh svn2cl
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css
+ doman svn2cl.1
+}
+
+pkg_postinst() {
+ elog "You can find samples of svn2html.css and authors.xml in"
+ elog "/usr/share/doc/${PF}/"
+ elog "Read man page for details."
+}