summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
commit4fda045f90a4e301329bddb766e2e12a0b4401de (patch)
tree1d486767bfd9de15d6c11d341408385eb7f7debe /dev-vcs
parent965058196f44550f3bc491dd85064071e085b776 (diff)
gentoo auto-resync : 14:02:2025 - 00:13:14
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin12023 -> 12020 bytes
-rw-r--r--dev-vcs/topgit/Manifest2
-rw-r--r--dev-vcs/topgit/topgit-0.19.14.ebuild38
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 6ae80565d202..e5640fae881a 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/topgit/Manifest b/dev-vcs/topgit/Manifest
index 25dcfd4f73cf..2b9fca87bee0 100644
--- a/dev-vcs/topgit/Manifest
+++ b/dev-vcs/topgit/Manifest
@@ -1,3 +1,5 @@
DIST topgit-0.19.13.tar.gz 355721 BLAKE2B 0f70d7720d0ca2f7724fe5fa3bb100c7f812c0bb18fd9acb4897487d90f31da957bc0b4e47e9dcdd08594366fb31c4f46447cf78989f828f337edd8f8f231bf3 SHA512 8e477504c5f873651854c9412864c9dcb0ee35d0349b65e7c5d618a0add0fad3f749381edbe17195981bae3ff9f0e7323286abf7a5c6b744721ba2cc2a5d40d4
+DIST topgit-0.19.14.tar.gz 358244 BLAKE2B 562e7ef42d662bb20e6da2dfeb960c3cb9d85378ac0fa6c9210cebc66b74aec63859639af9be075b8b8b432684be794b475645dc6517474d3151200a65d5ca6e SHA512 dabc511317211f5ad736675759f7920d3a5bb67c257bb8a0f3d9334e01fe1a60773c54b2f430a67a259bfe062e5741aaa33de213116d09a2193cfb8b7adf42de
EBUILD topgit-0.19.13.ebuild 870 BLAKE2B 4e5704b99b5799fe2d24464bca09a2f81a0b3d8ec6e633061d42b5417280b19e610d545bc44046ee7971f81c2f5fa251043761515f0ecedd9b9baad9bb50f806 SHA512 233e5d0445b924aedc895b7e14a74ba40aa2d392fc637d58d7a009ff9e345db849d81afeee86aabee2d49d726b21394ba4147984f0c91cb35b580cbea7f7f8d5
+EBUILD topgit-0.19.14.ebuild 833 BLAKE2B c261c98eb509771c19f6a0825db802d9fe453b11a2fdacbbcc1f1c815e234d39a28c2e3aa6d2a48e2229a90eb5f01585193bf3013c288bc15951da23eaa4e9be SHA512 cf4da6eab3793c61c1be26fc3bf08ead146a2a46eb27fcf420bafa777cb5a20a344141d0da055989f465aad996ac9aee6ba5602a360bb0d056eeb19aa82a97fa
MISC metadata.xml 486 BLAKE2B 44790d7afe48d2d2f36bd2b2c946d842a71ea76fcfa5297541f036531e82059e8d1f0e712402cbab4c45fdeaebfe7841e418da3a6655e4fefb2d994cf439ca62 SHA512 0336f1e67faf3a7d3645e72cec0329ea3fdcd293a44b1808abffaf87b381d80509988a7fa26e29d3c50510d110bd01373e279547fac400782d3c1b9eba20dbdb
diff --git a/dev-vcs/topgit/topgit-0.19.14.ebuild b/dev-vcs/topgit/topgit-0.19.14.ebuild
new file mode 100644
index 000000000000..b107a5cd92ef
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.19.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://mackyle.github.io/topgit/topgit.html https://github.com/mackyle/topgit"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-vcs/git-2.10.0"
+BDEPEND="
+ dev-lang/perl
+ app-alternatives/awk
+"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_test() {
+ # Needed to run tests properly (#739088)
+ emake T="" test
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" sharedir="/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}