summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-23 03:47:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-23 03:47:58 +0100
commit76639e956cb332de1bfbf50143f11084d2686c65 (patch)
tree119f7b60a809a7fd56a4b5d1a5ebb6efbc815b9c /dev-vcs
parent9368ace94caa5cdda868a0dbb7c75a3fc7a2b911 (diff)
gentoo auto-resync : 23:08:2023 - 03:47:58
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin11352 -> 11354 bytes
-rw-r--r--dev-vcs/pre-commit/Manifest3
-rw-r--r--dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch44
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.0.4.ebuild56
4 files changed, 0 insertions, 103 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 8eecb78fb403..51d2054eef8b 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index c73a44b34e00..4d4c48a9f925 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,7 +1,4 @@
-AUX pre-commit-2.20.0-tests_git_file_transport.patch 2021 BLAKE2B 764b353d3268176162ae2a5d6fc97c0cb9ad7d2cd5de69f19f8fcd78c8bba507f25f53cd3d6c767fbcb9b9f885f8eceda2fc82d1b6ed54f34c1d4907d0fddd72 SHA512 6d8a3b5c9026f5c20a84d581ca92d74743643de010af468217b2f44324560d56b504e033ccebe102194492b25a01a4ed503995c222561ce406577fce211c2eab
AUX pre-commit-3.1.1-tests_git_file_transport.patch 1527 BLAKE2B 18d047f3b8a6fdc3da77aa5b8d9f60970ab5b69adc3790489ceffc17839a4cd21ed46428c5e2e98b50278b2c4dc49e35a09dd778000546828327ae96f910f95b SHA512 36cb194250dc0fefad2900452447ab590f678e6cd5edf07a7f072363733c263b7cb1167297c465a9372d4a38ab77a6c057046c66b872a958132a97d1a937d029
-DIST pre-commit-3.0.4.gh.tar.gz 264952 BLAKE2B 3c45da675d5a1a1fc115db0ef7186c1ec1e5a6d6d9353c5a53dba85a14de2c94bafe0ef9e8d0b04bae55ded81890d726997e695c95889719096205e1b212a237 SHA512 d51aca29b50f67ae42aa70d849939e6af96ff64c6fb214cddbc5a35cacebb8a54a4911110d0615a1a499516fcc2a06bb47d7e11da84ef636c3fcfdc8d2cbe343
DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
-EBUILD pre-commit-3.0.4.ebuild 1711 BLAKE2B 3c1f5768aedd958ed6a9ccbb9396076084255f645e7339cc04b73d3fd4e976f4b1562a405125a40c941bb02adfde3e1926700e45c1fd29d2fcda55aa64a41645 SHA512 8790c810a8dfb7fd489536e45ba148c22e106c8cdb6641cd7a936124a3777e907163ad801b0252707273320505dbb9233161d3a5d7fd60e6c2b1fe0d434e1c01
EBUILD pre-commit-3.3.3.ebuild 1734 BLAKE2B b88b61f19eecb5e19f12d150b088440efdeb54bc2269cd322de4bafcd04ca6aebfc6d851cc4af607415367f61f77a9e93ca93e7f65d1b3ee83b5353a189ca3fa SHA512 650f9eefae6e2bcdc5718cec361f9a5a93759fcdb6b2066be6bc927b169d12e609fff09337350431381ba14d567ada4467586b2b97dafa6df38cc9a40648abaa
MISC metadata.xml 380 BLAKE2B 99842a97367e91700c6f714f427b7b3d4b7212c401abae5ab715dfaa724776f02fe250184a33504d3433bb58cd5679af59a32ec21a7e7432481160dab36a4d95 SHA512 45330930d1e58fc1de0fd0ba55cd488dee96579ceab3be5073b91ff8f4f2b9adefff533dbfa5b0e8b23fbb648d45c0b7b4073a1ec57b586600cc2bf6347e0bbb
diff --git a/dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch b/dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch
deleted file mode 100644
index 9845e1311da5..000000000000
--- a/dev-vcs/pre-commit/files/pre-commit-2.20.0-tests_git_file_transport.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/tests/commands/install_uninstall_test.py
-+++ b/tests/commands/install_uninstall_test.py
-@@ -176,7 +176,7 @@
- def test_install_in_submodule_and_run(tempdir_factory, store):
- src_path = make_consuming_repo(tempdir_factory, 'script_hooks_repo')
- parent_path = git_dir(tempdir_factory)
-- cmd_output('git', 'submodule', 'add', src_path, 'sub', cwd=parent_path)
-+ cmd_output('git', '-c', 'protocol.file.allow=always', 'submodule', 'add', src_path, 'sub', cwd=parent_path)
- git_commit(cwd=parent_path)
-
- sub_pth = os.path.join(parent_path, 'sub')
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -90,7 +90,7 @@
- git_dir_1 = git_dir(tempdir_factory)
- git_dir_2 = git_dir(tempdir_factory)
- git_commit(msg=in_conflicting_submodule.__name__, cwd=git_dir_2)
-- cmd_output('git', 'submodule', 'add', git_dir_2, 'sub', cwd=git_dir_1)
-+ cmd_output('git', '-c', 'protocol.file.allow=always', 'submodule', 'add', git_dir_2, 'sub', cwd=git_dir_1)
- with cwd(os.path.join(git_dir_1, 'sub')):
- _make_conflict()
- yield
---- a/tests/repository_test.py
-+++ b/tests/repository_test.py
-@@ -443,7 +443,7 @@
- repo.join('main.go').write(main_go)
- cmd_output('git', '-C', str(repo), 'init', '.')
- cmd_output('git', '-C', str(repo), 'add', '.')
-- cmd_output('git', '-C', str(repo), 'submodule', 'add', str(sub), 'sub')
-+ cmd_output('git', '-C', str(repo), '-c', 'protocol.file.allow=always', 'submodule', 'add', str(sub), 'sub')
- git.commit(str(repo))
-
- config = make_config_from_repo(str(repo))
---- a/tests/staged_files_only_test.py
-+++ b/tests/staged_files_only_test.py
-@@ -207,7 +207,7 @@
- cmd_output('git', 'add', 'bar')
- git_commit()
- cmd_output(
-- 'git', 'submodule', 'add', repo_with_commits.path, 'sub',
-+ 'git', '-c', 'protocol.file.allow=always', 'submodule', 'add', repo_with_commits.path, 'sub',
- )
- checkout_submodule(repo_with_commits.rev1)
- cmd_output('git', 'add', 'sub')
diff --git a/dev-vcs/pre-commit/pre-commit-3.0.4.ebuild b/dev-vcs/pre-commit/pre-commit-3.0.4.ebuild
deleted file mode 100644
index 11b7b05c956f..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.0.4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- sys-apps/coreutils[-multicall]
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.20.0-tests_git_file_transport.patch
-)
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest