summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
commitc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (patch)
tree8fcd60c2f36e3da5e4d545f47ddf14680f0d51e5 /dev-vcs
parent159ec3f090554ee5d7f61b2da553833fb7566f99 (diff)
gentoo auto-resync : 26:10:2023 - 02:47:53
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin11520 -> 11517 bytes
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.5.0.ebuild58
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index 1f7f219851af..59eb4bb15469 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 4d4c48a9f925..e5e7f1b04db4 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,4 +1,6 @@
AUX pre-commit-3.1.1-tests_git_file_transport.patch 1527 BLAKE2B 18d047f3b8a6fdc3da77aa5b8d9f60970ab5b69adc3790489ceffc17839a4cd21ed46428c5e2e98b50278b2c4dc49e35a09dd778000546828327ae96f910f95b SHA512 36cb194250dc0fefad2900452447ab590f678e6cd5edf07a7f072363733c263b7cb1167297c465a9372d4a38ab77a6c057046c66b872a958132a97d1a937d029
DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
+DIST pre-commit-3.5.0.gh.tar.gz 268906 BLAKE2B 7585aae950f63845cf132b3472662f19f87942b886687551fbf69e4adb20513304d2c4d399c12619e6c7f9aeab0a6a57c3fe3cd271a29470bedc9480b3b34256 SHA512 c7504fa2d3ba70def3361af0fcc2f7a5454325125e27f44fbaa60906f1ac35b0fa1b646eaf326cb04d4d042ecb6786fbb8e9166099df1e687fa2a64a8113c244
EBUILD pre-commit-3.3.3.ebuild 1734 BLAKE2B b88b61f19eecb5e19f12d150b088440efdeb54bc2269cd322de4bafcd04ca6aebfc6d851cc4af607415367f61f77a9e93ca93e7f65d1b3ee83b5353a189ca3fa SHA512 650f9eefae6e2bcdc5718cec361f9a5a93759fcdb6b2066be6bc927b169d12e609fff09337350431381ba14d567ada4467586b2b97dafa6df38cc9a40648abaa
+EBUILD pre-commit-3.5.0.ebuild 1764 BLAKE2B 3753954d2324cf097a9221e756664ef99c1c3452854b531e78d10038c3c354e01cd7474a6f338edf34d8858421a253034638f89d955cc6db19c8b1d4f7a0f30b SHA512 322097b714d94e2fd35527090fc0ab6201c531632311034b0de3c2454df8cb18da479de3aaef34b272b463c66c34bcd15fc75f21f1ebca0507f9face6dca76e6
MISC metadata.xml 380 BLAKE2B 99842a97367e91700c6f714f427b7b3d4b7212c401abae5ab715dfaa724776f02fe250184a33504d3433bb58cd5679af59a32ec21a7e7432481160dab36a4d95 SHA512 45330930d1e58fc1de0fd0ba55cd488dee96579ceab3be5073b91ff8f4f2b9adefff533dbfa5b0e8b23fbb648d45c0b7b4073a1ec57b586600cc2bf6347e0bbb
diff --git a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
new file mode 100644
index 000000000000..e6d46da41754
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by nodeenv
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')"
+# coreutils requirement: see Bug #885559
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ sys-apps/coreutils[-multicall]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
+)
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest