summaryrefslogtreecommitdiff
path: root/eclass/distutils-r1.eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /eclass/distutils-r1.eclass
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index fae25ea8a5ec..302651858352 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: distutils-r1.eclass
@@ -86,6 +86,8 @@ esac
# - no -- do not add the dependency (pure distutils package)
# - bdepend -- add it to BDEPEND (the default)
# - rdepend -- add it to BDEPEND+RDEPEND (when using entry_points)
+# - manual -- do not add the depedency and suppress the checks
+# (assumes you will take care of doing it correctly)
#
# This variable is effective only if DISTUTILS_OPTIONAL is disabled.
# It needs to be set before the inherit line.
@@ -116,7 +118,7 @@ _distutils_set_globals() {
local bdep=${rdep}
case ${DISTUTILS_USE_SETUPTOOLS} in
- no)
+ no|manual)
;;
bdepend)
bdep+=" dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -436,6 +438,7 @@ distutils_enable_tests() {
# incorrectly.
_distutils_verify_use_setuptools() {
[[ ${DISTUTILS_OPTIONAL} ]] && return
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
# ok, those are cheap greps. we can try toimprove them if we hit
# false positives.
@@ -444,7 +447,7 @@ _distutils_verify_use_setuptools() {
# as a special case, setuptools provides itself ;-)
:
elif grep -E -q -s '(from|import)\s+setuptools' setup.py; then
- if grep -E -q -s 'entry_points\s+=' setup.py; then
+ if grep -E -q -s 'entry_points\s*=' setup.py; then
expected=rdepend
else
expected=bdepend