summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /eclass
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin36382 -> 36384 bytes
-rw-r--r--eclass/ada.eclass2
-rw-r--r--eclass/distutils-r1.eclass2
-rw-r--r--eclass/java-ant-2.eclass6
-rw-r--r--eclass/java-osgi.eclass4
-rw-r--r--eclass/java-pkg-opt-2.eclass4
-rw-r--r--eclass/java-utils-2.eclass9
-rw-r--r--eclass/java-virtuals-2.eclass6
-rw-r--r--eclass/multilib.eclass41
-rwxr-xr-xeclass/tests/distutils-r1.sh6
-rwxr-xr-xeclass/tests/distutils-r1_single.sh2
-rwxr-xr-xeclass/tests/python-utils-r1.sh48
-rw-r--r--eclass/toolchain.eclass48
-rw-r--r--eclass/webapp.eclass6
14 files changed, 70 insertions, 114 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index ab1563632e54..b6913496bd25 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/ada.eclass b/eclass/ada.eclass
index fe28142e94ae..b8deb31255c2 100644
--- a/eclass/ada.eclass
+++ b/eclass/ada.eclass
@@ -246,7 +246,7 @@ ada_export() {
debug-print "${FUNCNAME}: GNATCHOP = ${GNATCHOP}"
;;
ADA_PKG_DEP)
- ADA_PKG_DEP="dev-lang/gnat-gpl:${slot}"
+ ADA_PKG_DEP="dev-lang/gnat-gpl:${slot}[ada]"
# use-dep
if [[ ${ADA_REQ_USE} ]]; then
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index d07dfac246a4..1b50dc4e74b4 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -130,7 +130,7 @@ _distutils_set_globals() {
rdep+=" ${setuptools_dep}"
;;
pyproject.toml)
- bdep+=' >=dev-python/pyproject2setuppy-18[${PYTHON_USEDEP}]'
+ bdep+=' >=dev-python/pyproject2setuppy-22[${PYTHON_USEDEP}]'
;;
*)
die "Invalid DISTUTILS_USE_SETUPTOOLS=${DISTUTILS_USE_SETUPTOOLS}"
diff --git a/eclass/java-ant-2.eclass b/eclass/java-ant-2.eclass
index 501d17ef229e..438b0dbb5001 100644
--- a/eclass/java-ant-2.eclass
+++ b/eclass/java-ant-2.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# kiorky <kiorky@cryptelium.net>
# Petteri Räty <betelgeuse@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @PROVIDES: java-utils-2
# @BLURB: eclass for ant based Java packages
# @DESCRIPTION:
@@ -18,7 +18,7 @@
inherit java-utils-2 multilib
case ${EAPI:-0} in
- [567]) ;;
+ [5678]) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -73,7 +73,7 @@ fi
# constructed above.
JAVA_ANT_E_DEPEND="${JAVA_ANT_E_DEPEND}
${ANT_TASKS_DEPEND}
- >=dev-java/javatoolkit-0.3.0-r2"
+ dev-java/javatoolkit"
# this eclass must be inherited after java-pkg-2 or java-pkg-opt-2
# if it's java-pkg-opt-2, ant dependencies are pulled based on USE flag
diff --git a/eclass/java-osgi.eclass b/eclass/java-osgi.eclass
index 74c7c1a07f5c..f2f55772e873 100644
--- a/eclass/java-osgi.eclass
+++ b/eclass/java-osgi.eclass
@@ -6,7 +6,7 @@
# java@gentoo.org
# @AUTHOR:
# Java maintainers <java@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @PROVIDES: java-utils-2
# @BLURB: Java OSGi eclass
# @DESCRIPTION:
@@ -16,7 +16,7 @@
# could extend this so that Gentoo Java system would be fully OSGi compliant.
case ${EAPI:-0} in
- [567]) ;;
+ [5678]) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
diff --git a/eclass/java-pkg-opt-2.eclass b/eclass/java-pkg-opt-2.eclass
index 79833c98ea6b..92f2cb53145d 100644
--- a/eclass/java-pkg-opt-2.eclass
+++ b/eclass/java-pkg-opt-2.eclass
@@ -6,7 +6,7 @@
# java@gentoo.org
# @AUTHOR:
# Thomas Matthijs <axxo@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @PROVIDES: java-utils-2
# @BLURB: Eclass for package with optional Java support
# @DESCRIPTION:
@@ -14,7 +14,7 @@
# support.
case ${EAPI:-0} in
- [567]) ;;
+ [5678]) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index 050a5c4847a6..d3d462aa9442 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -1,4 +1,4 @@
-# Copyright 2004-2021 Gentoo Authors
+# Copyright 2004-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: java-utils-2.eclass
@@ -29,8 +29,6 @@ _JAVA_UTILS_2_ECLASS=1
# Keep versionator inheritance in case consumers are using it implicitly.
[[ ${EAPI} == [56] ]] && inherit eapi7-ver eutils multilib versionator
-IUSE="elibc_FreeBSD"
-
# Make sure we use java-config-2
export WANT_JAVA_CONFIG="2"
@@ -1689,11 +1687,8 @@ java-pkg_javac-args() {
java-pkg_get-jni-cflags() {
local flags="-I${JAVA_HOME}/include"
- local platform="linux"
- use elibc_FreeBSD && platform="freebsd"
-
# TODO do a check that the directories are valid
- flags="${flags} -I${JAVA_HOME}/include/${platform}"
+ flags="${flags} -I${JAVA_HOME}/include/linux"
echo ${flags}
}
diff --git a/eclass/java-virtuals-2.eclass b/eclass/java-virtuals-2.eclass
index dedbf2f26195..e929a7e1ceeb 100644
--- a/eclass/java-virtuals-2.eclass
+++ b/eclass/java-virtuals-2.eclass
@@ -6,14 +6,14 @@
# java@gentoo.org
# @AUTHOR:
# Original Author: Alistair John Bush <ali_bush@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6
+# @SUPPORTED_EAPIS: 5 6 8
# @BLURB: Java virtuals eclass
# @DESCRIPTION:
# To provide a default (and only) src_install function for ebuilds in the
# java-virtuals category.
case ${EAPI:-0} in
- [56]) ;;
+ [568]) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -22,7 +22,7 @@ _JAVA_VIRTUALS_2_ECLASS=1
inherit java-utils-2
-DEPEND=">=dev-java/java-config-2.2.0-r3"
+DEPEND="dev-java/java-config"
RDEPEND="${DEPEND}"
S="${WORKDIR}"
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index 483f8d10c721..fadd371f3ca7 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -368,6 +368,15 @@ multilib_env() {
;;
esac
;;
+ loongarch64*)
+ export CFLAGS_lp64d=${CFLAGS_lp64d--mabi=lp64d}
+ export CHOST_lp64d=${CTARGET}
+ export CTARGET_lp64d=${CTARGET}
+ export LIBDIR_lp64d=${LIBDIR_lp64d-lib64}
+
+ : ${MULTILIB_ABIS=lp64d}
+ : ${DEFAULT_ABI=lp64d}
+ ;;
mips64*|mipsisa64*)
export CFLAGS_o32=${CFLAGS_o32--mabi=32}
export CHOST_o32=${CTARGET/mips64/mips}
@@ -403,7 +412,18 @@ multilib_env() {
: ${DEFAULT_ABI=ppc64}
;;
riscv64*)
- export CFLAGS_lp64d=${CFLAGS_lp64d--mabi=lp64d -march=rv64imafdc}
+ : ${MULTILIB_ABIS=lp64d lp64 ilp32d ilp32}
+ : ${DEFAULT_ABI=lp64d}
+
+ # the default abi is set to the 1-level libdir default
+
+ local __libdir_riscvdefaultabi_variable="LIBDIR_${DEFAULT_ABI}"
+ local __libdir_riscvdefaultabi=${!__libdir_riscvdefaultabi_variable}
+ export ${__libdir_riscvdefaultabi_variable}=${__libdir_riscvdefaultabi:-lib64}
+
+ # all other abi are set to the 2-level libdir default
+
+ export CFLAGS_lp64d=${CFLAGS_lp64d--mabi=lp64d -march=rv64gc}
export CHOST_lp64d=${CTARGET}
export CTARGET_lp64d=${CTARGET}
export LIBDIR_lp64d=${LIBDIR_lp64d-lib64/lp64d}
@@ -422,12 +442,20 @@ multilib_env() {
export CHOST_ilp32=${CTARGET/riscv64/riscv32}
export CTARGET_ilp32=${CTARGET/riscv64/riscv32}
export LIBDIR_ilp32=${LIBDIR_ilp32-lib32/ilp32}
-
- : ${MULTILIB_ABIS=lp64d lp64 ilp32d ilp32}
- : ${DEFAULT_ABI=lp64d}
;;
riscv32*)
- export CFLAGS_ilp32d=${CFLAGS_ilp32d--mabi=ilp32d}
+ : ${MULTILIB_ABIS=ilp32d ilp32}
+ : ${DEFAULT_ABI=ilp32d}
+
+ # the default abi is set to the 1-level libdir default
+
+ local __libdir_riscvdefaultabi_variable="LIBDIR_${DEFAULT_ABI}"
+ local __libdir_riscvdefaultabi=${!__libdir_riscvdefaultabi_variable}
+ export ${__libdir_riscvdefaultabi_variable}=${__libdir_riscvdefaultabi:-lib}
+
+ # all other abi are set to the 2-level libdir default
+
+ export CFLAGS_ilp32d=${CFLAGS_ilp32d--mabi=ilp32d -march=rv32imafdc}
export CHOST_ilp32d=${CTARGET}
export CTARGET_ilp32d=${CTARGET}
export LIBDIR_ilp32d=${LIBDIR_ilp32d-lib32/ilp32d}
@@ -436,9 +464,6 @@ multilib_env() {
export CHOST_ilp32=${CTARGET}
export CTARGET_ilp32=${CTARGET}
export LIBDIR_ilp32=${LIBDIR_ilp32-lib32/ilp32}
-
- : ${MULTILIB_ABIS=ilp32d ilp32}
- : ${DEFAULT_ABI=ilp32d}
;;
s390x*)
export CFLAGS_s390=${CFLAGS_s390--m31} # the 31 is not a typo
diff --git a/eclass/tests/distutils-r1.sh b/eclass/tests/distutils-r1.sh
index 163a509b3068..1ccb1dfbc523 100755
--- a/eclass/tests/distutils-r1.sh
+++ b/eclass/tests/distutils-r1.sh
@@ -97,7 +97,7 @@ tend
einfo distutils_enable_tests
eindent
BASE_IUSE="python_targets_python3_8"
-BASE_DEPS="python_targets_python3_8? ( dev-lang/python:3.8 ) >=dev-lang/python-exec-2:=[python_targets_python3_8(-)?,-python_single_target_python3_8(-)]"
+BASE_DEPS="python_targets_python3_8? ( dev-lang/python:3.8 ) >=dev-lang/python-exec-2:=[python_targets_python3_8(-)?]"
TEST_RESTRICT="!test? ( test )"
einfo "empty RDEPEND"
@@ -131,11 +131,11 @@ eoutdent
einfo DISTUTILS_USE_SETUPTOOLS
eindent
-SETUPTOOLS_DEP=">=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,-python_single_target_python3_8(-)]"
+SETUPTOOLS_DEP=">=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?]"
test-DISTUTILS_USE_SETUPTOOLS no "${BASE_DEPS}" "${BASE_DEPS}"
test-DISTUTILS_USE_SETUPTOOLS bdepend "${BASE_DEPS} ${SETUPTOOLS_DEP}" "${BASE_DEPS}"
test-DISTUTILS_USE_SETUPTOOLS rdepend "${BASE_DEPS} ${SETUPTOOLS_DEP}" "${BASE_DEPS} ${SETUPTOOLS_DEP}"
-test-DISTUTILS_USE_SETUPTOOLS pyproject.toml "${BASE_DEPS} dev-python/pyproject2setuppy[python_targets_python3_8(-)?,-python_single_target_python3_8(-)]" "${BASE_DEPS}"
+test-DISTUTILS_USE_SETUPTOOLS pyproject.toml "${BASE_DEPS} >=dev-python/pyproject2setuppy-22[python_targets_python3_8(-)?]" "${BASE_DEPS}"
test-DISTUTILS_USE_SETUPTOOLS manual "${BASE_DEPS}" "${BASE_DEPS}"
eoutdent
diff --git a/eclass/tests/distutils-r1_single.sh b/eclass/tests/distutils-r1_single.sh
index fb177261d0a0..56b62ca0e90f 100755
--- a/eclass/tests/distutils-r1_single.sh
+++ b/eclass/tests/distutils-r1_single.sh
@@ -115,7 +115,7 @@ SETUPTOOLS_DEP="python_single_target_python3_8? ( >=dev-python/setuptools-42.0.2
test-DISTUTILS_USE_SETUPTOOLS no "${BASE_DEPS}" "${BASE_DEPS}"
test-DISTUTILS_USE_SETUPTOOLS bdepend "${BASE_DEPS} ${SETUPTOOLS_DEP}" "${BASE_DEPS}"
test-DISTUTILS_USE_SETUPTOOLS rdepend "${BASE_DEPS} ${SETUPTOOLS_DEP}" "${BASE_DEPS} ${SETUPTOOLS_DEP}"
-test-DISTUTILS_USE_SETUPTOOLS pyproject.toml "${BASE_DEPS} python_single_target_python3_8? ( dev-python/pyproject2setuppy[python_targets_python3_8(-)] )" "${BASE_DEPS}"
+test-DISTUTILS_USE_SETUPTOOLS pyproject.toml "${BASE_DEPS} python_single_target_python3_8? ( >=dev-python/pyproject2setuppy-22[python_targets_python3_8(-)] )" "${BASE_DEPS}"
test-DISTUTILS_USE_SETUPTOOLS manual "${BASE_DEPS}" "${BASE_DEPS}"
eoutdent
diff --git a/eclass/tests/python-utils-r1.sh b/eclass/tests/python-utils-r1.sh
index 63a94c90b715..7ba4a864ff10 100755
--- a/eclass/tests/python-utils-r1.sh
+++ b/eclass/tests/python-utils-r1.sh
@@ -151,7 +151,7 @@ test_var EPYTHON pypy3 pypy3
test_var PYTHON pypy3 /usr/bin/pypy3
if [[ -x /usr/bin/pypy3 ]]; then
test_var PYTHON_SITEDIR pypy3 "/usr/lib*/pypy3.?/site-packages"
- test_var PYTHON_INCLUDEDIR pypy3 "/usr/lib*/pypy3.?/include"
+ test_var PYTHON_INCLUDEDIR pypy3 "/usr/include/pypy3.?"
fi
test_var PYTHON_PKG_DEP pypy3 '*dev-python/pypy3*:0='
test_var PYTHON_SCRIPTDIR pypy3 /usr/lib/python-exec/pypy3
@@ -162,68 +162,44 @@ test_is "python_is_python3 pypy" 1
test_is "python_is_python3 pypy3" 0
# generic shebangs
-test_fix_shebang '#!/usr/bin/python' python2.7 '#!/usr/bin/python2.7'
test_fix_shebang '#!/usr/bin/python' python3.6 '#!/usr/bin/python3.6'
test_fix_shebang '#!/usr/bin/python' pypy3 '#!/usr/bin/pypy3'
# python2/python3 matching
-test_fix_shebang '#!/usr/bin/python2' python2.7 '#!/usr/bin/python2.7'
-test_fix_shebang '#!/usr/bin/python3' python2.7 FAIL
-test_fix_shebang '#!/usr/bin/python3' python2.7 '#!/usr/bin/python2.7' --force
test_fix_shebang '#!/usr/bin/python3' python3.6 '#!/usr/bin/python3.6'
test_fix_shebang '#!/usr/bin/python2' python3.6 FAIL
test_fix_shebang '#!/usr/bin/python2' python3.6 '#!/usr/bin/python3.6' --force
# pythonX.Y matching (those mostly test the patterns)
-test_fix_shebang '#!/usr/bin/python2.7' python2.7 '#!/usr/bin/python2.7'
test_fix_shebang '#!/usr/bin/python2.7' python3.2 FAIL
test_fix_shebang '#!/usr/bin/python2.7' python3.2 '#!/usr/bin/python3.2' --force
test_fix_shebang '#!/usr/bin/python3.2' python3.2 '#!/usr/bin/python3.2'
-test_fix_shebang '#!/usr/bin/python3.2' python2.7 FAIL
-test_fix_shebang '#!/usr/bin/python3.2' python2.7 '#!/usr/bin/python2.7' --force
-test_fix_shebang '#!/usr/bin/pypy' python2.7 FAIL
-test_fix_shebang '#!/usr/bin/pypy' python2.7 '#!/usr/bin/python2.7' --force
# fancy path handling
test_fix_shebang '#!/mnt/python2/usr/bin/python' python3.6 \
'#!/mnt/python2/usr/bin/python3.6'
-test_fix_shebang '#!/mnt/python2/usr/bin/python2' python2.7 \
- '#!/mnt/python2/usr/bin/python2.7'
-test_fix_shebang '#!/mnt/python2/usr/bin/env python' python2.7 \
- '#!/mnt/python2/usr/bin/env python2.7'
-test_fix_shebang '#!/mnt/python2/usr/bin/python2 python2' python2.7 \
- '#!/mnt/python2/usr/bin/python2.7 python2'
-test_fix_shebang '#!/mnt/python2/usr/bin/python3 python2' python2.7 FAIL
-test_fix_shebang '#!/mnt/python2/usr/bin/python3 python2' python2.7 \
- '#!/mnt/python2/usr/bin/python2.7 python2' --force
-test_fix_shebang '#!/usr/bin/foo' python2.7 FAIL
+test_fix_shebang '#!/mnt/python2/usr/bin/python3' python3.8 \
+ '#!/mnt/python2/usr/bin/python3.8'
+test_fix_shebang '#!/mnt/python2/usr/bin/env python' python3.8 \
+ '#!/mnt/python2/usr/bin/env python3.8'
+test_fix_shebang '#!/mnt/python2/usr/bin/python3 python3' python3.8 \
+ '#!/mnt/python2/usr/bin/python3.8 python3'
+test_fix_shebang '#!/mnt/python2/usr/bin/python2 python3' python3.8 FAIL
+test_fix_shebang '#!/mnt/python2/usr/bin/python2 python3' python3.8 \
+ '#!/mnt/python2/usr/bin/python3.8 python3' --force
+test_fix_shebang '#!/usr/bin/foo' python3.8 FAIL
# regression test for bug #522080
-test_fix_shebang '#!/usr/bin/python ' python2.7 '#!/usr/bin/python2.7 '
+test_fix_shebang '#!/usr/bin/python ' python3.8 '#!/usr/bin/python3.8 '
# check _python_impl_matches behavior
-test_is "_python_impl_matches python2_7 -2" 0
-test_is "_python_impl_matches python3_6 -2" 1
-test_is "_python_impl_matches python3_7 -2" 1
-test_is "_python_impl_matches pypy3 -2" 1
-test_is "_python_impl_matches python2_7 -3" 1
test_is "_python_impl_matches python3_6 -3" 0
test_is "_python_impl_matches python3_7 -3" 0
test_is "_python_impl_matches pypy3 -3" 0
-test_is "_python_impl_matches python2_7 -2 python3_6" 0
-test_is "_python_impl_matches python3_6 -2 python3_6" 0
-test_is "_python_impl_matches python3_7 -2 python3_6" 1
-test_is "_python_impl_matches pypy3 -2 python3_6" 1
-test_is "_python_impl_matches python2_7 pypy3 -2 python3_6" 0
-test_is "_python_impl_matches python3_6 pypy3 -2 python3_6" 0
-test_is "_python_impl_matches python3_7 pypy3 -2 python3_6" 1
-test_is "_python_impl_matches pypy3 pypy3 -2 python3_6" 0
set -f
-test_is "_python_impl_matches python2_7 pypy*" 1
test_is "_python_impl_matches python3_6 pypy*" 1
test_is "_python_impl_matches python3_7 pypy*" 1
test_is "_python_impl_matches pypy3 pypy*" 0
-test_is "_python_impl_matches python2_7 python*" 0
test_is "_python_impl_matches python3_6 python*" 0
test_is "_python_impl_matches python3_7 python*" 0
test_is "_python_impl_matches pypy3 python*" 1
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index fd03ba176276..61718f0d9a01 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: toolchain.eclass
@@ -359,7 +359,6 @@ gentoo_urls() {
# with a Cygwin target.
get_gcc_src_uri() {
export PATCH_GCC_VER=${PATCH_GCC_VER:-${GCC_RELEASE_VER}}
- export UCLIBC_GCC_VER=${UCLIBC_GCC_VER:-${PATCH_GCC_VER}}
export MUSL_GCC_VER=${MUSL_GCC_VER:-${PATCH_GCC_VER}}
export PIE_GCC_VER=${PIE_GCC_VER:-${GCC_RELEASE_VER}}
export HTB_GCC_VER=${HTB_GCC_VER:-${GCC_RELEASE_VER}}
@@ -373,7 +372,7 @@ get_gcc_src_uri() {
# pull gcc tarball from another location. Frequently used by gnat-gpl.
GCC_SRC_URI="${GCC_TARBALL_SRC_URI}"
elif [[ -n ${SNAPSHOT} ]] ; then
- GCC_SRC_URI="ftp://gcc.gnu.org/pub/gcc/snapshots/${SNAPSHOT}/gcc-${SNAPSHOT}.tar.xz"
+ GCC_SRC_URI="https://gcc.gnu.org/pub/gcc/snapshots/${SNAPSHOT}/gcc-${SNAPSHOT}.tar.xz"
else
if tc_version_is_between 5.5 6 || tc_version_is_between 6.4 7 || tc_version_is_at_least 7.2 ; then
GCC_SRC_URI="mirror://gnu/gcc/gcc-${GCC_PV}/gcc-${GCC_RELEASE_VER}.tar.xz"
@@ -382,8 +381,6 @@ get_gcc_src_uri() {
fi
fi
- [[ -n ${UCLIBC_VER} ]] && \
- GCC_SRC_URI+=" $(gentoo_urls gcc-${UCLIBC_GCC_VER}-uclibc-patches-${UCLIBC_VER}.tar.bz2)"
[[ -n ${PATCH_VER} ]] && \
GCC_SRC_URI+=" $(gentoo_urls gcc-${PATCH_GCC_VER}-patches-${PATCH_VER}.tar.bz2)"
[[ -n ${MUSL_VER} ]] && \
@@ -557,10 +554,6 @@ do_gcc_gentoo_patches() {
BRANDING_GCC_PKGVERSION="${BRANDING_GCC_PKGVERSION} p${PATCH_VER}"
fi
- if [[ -n ${UCLIBC_VER} ]] ; then
- tc_apply_patches "Applying uClibc patches ..." "${WORKDIR}"/uclibc/*.patch
- fi
-
if [[ -n ${MUSL_VER} ]] && [[ ${CTARGET} == *musl* ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
# We don't want to apply some patches when cross-compiling.
@@ -923,21 +916,9 @@ toolchain_src_configure() {
# Undoing it here.
confgcc+=( --disable-libstdcxx-time )
;;
- *-freebsd*) needed_libc=freebsd-lib;;
*-gnu*) needed_libc=glibc;;
*-klibc) needed_libc=klibc;;
*-musl*) needed_libc=musl;;
- *-uclibc*)
- # Enable shared library support only on targets
- # that support it: bug #291870
- if ! echo '#include <features.h>' | \
- $(tc-getCPP ${CTARGET}) -E -dD - 2>/dev/null | \
- grep -q __HAVE_SHARED__
- then
- confgcc+=( --disable-shared )
- fi
- needed_libc=uclibc-ng
- ;;
*-cygwin) needed_libc=cygwin;;
x86_64-*-mingw*|\
*-w64-mingw*) needed_libc=mingw64-runtime;;
@@ -991,14 +972,6 @@ toolchain_src_configure() {
# __cxa_atexit is "essential for fully standards-compliant handling of
# destructors", but apparently requires glibc.
case ${CTARGET} in
- *-uclibc*)
- if tc_has_feature nptl ; then
- confgcc+=(
- --disable-__cxa_atexit
- $(use_enable nptl tls)
- )
- fi
- ;;
*-elf|*-eabi)
confgcc+=( --with-newlib )
;;
@@ -1011,9 +984,6 @@ toolchain_src_configure() {
--enable-clocale=gnu
)
;;
- *-freebsd*)
- confgcc+=( --enable-__cxa_atexit )
- ;;
*-solaris*)
confgcc+=( --enable-__cxa_atexit )
;;
@@ -2301,8 +2271,6 @@ hardened_gcc_works() {
# $gcc_cv_ld_pie is unreliable as it simply take the output of
# `ld --help | grep -- -pie`, that reports the option in all cases, also if
# the loader doesn't actually load the resulting executables.
- # To avoid breakage, blacklist FreeBSD here at least
- [[ ${CTARGET} == *-freebsd* ]] && return 1
want_pie || return 1
_tc_use_if_iuse nopie && return 1
@@ -2324,17 +2292,9 @@ hardened_gcc_works() {
hardened_gcc_is_stable() {
local tocheck
if [[ $1 == "pie" ]] ; then
- if [[ ${CTARGET} == *-uclibc* ]] ; then
- tocheck=${PIE_UCLIBC_STABLE}
- else
- tocheck=${PIE_GLIBC_STABLE}
- fi
+ tocheck=${PIE_GLIBC_STABLE}
elif [[ $1 == "ssp" ]] ; then
- if [[ ${CTARGET} == *-uclibc* ]] ; then
- tocheck=${SSP_UCLIBC_STABLE}
- elif [[ ${CTARGET} == *-gnu* ]] ; then
- tocheck=${SSP_STABLE}
- fi
+ tocheck=${SSP_STABLE}
else
die "hardened_gcc_stable needs to be called with pie or ssp"
fi
diff --git a/eclass/webapp.eclass b/eclass/webapp.eclass
index 5ef7dbce03cf..7bdf28430b48 100644
--- a/eclass/webapp.eclass
+++ b/eclass/webapp.eclass
@@ -4,14 +4,14 @@
# @ECLASS: webapp.eclass
# @MAINTAINER:
# web-apps@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: functions for installing applications to run under a web server
# @DESCRIPTION:
# The webapp eclass contains functions to handle web applications with
# webapp-config. Part of the implementation of GLEP #11
case ${EAPI:-0} in
- [567]) ;;
+ [5678]) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -24,7 +24,7 @@ _WEBAPP_ECLASS=1
# @DESCRIPTION:
# An ebuild should use WEBAPP_DEPEND if a custom DEPEND needs to be built, most
# notably in combination with WEBAPP_OPTIONAL.
-WEBAPP_DEPEND=">=app-admin/webapp-config-1.50.15"
+WEBAPP_DEPEND="app-admin/webapp-config"
# @ECLASS-VARIABLE: WEBAPP_NO_AUTO_INSTALL
# @PRE_INHERIT