summaryrefslogtreecommitdiff
path: root/games-action/battalion/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/battalion/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/battalion/files')
-rw-r--r--games-action/battalion/files/battalion-1.4b-fix-build-system.patch55
-rw-r--r--games-action/battalion/files/battalion-1.4b-warning.patch12
2 files changed, 67 insertions, 0 deletions
diff --git a/games-action/battalion/files/battalion-1.4b-fix-build-system.patch b/games-action/battalion/files/battalion-1.4b-fix-build-system.patch
new file mode 100644
index 000000000000..fe209e1db953
--- /dev/null
+++ b/games-action/battalion/files/battalion-1.4b-fix-build-system.patch
@@ -0,0 +1,55 @@
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,6 @@
+ # (the program should compile with no warning messages - if you
+ # see a warning message please let me know about it)
+ # ------------------------------------------------------------
+-CC = cc
+
+
+ # STEP 2: IF YOU WANT TO COMPILE WITH THE MESA LIBRARIES THEN
+@@ -39,7 +38,8 @@
+ # ------------------------------------------------------------
+ #GLIB = -lMesaGL -lMesaGLU
+ # or
+-GLIB = -lGL -lGLU
++GLIB_CFLAGS = `pkg-config --cflags gl` `pkg-config --cflags glu`
++GLIB_LIBS = `pkg-config --libs gl` `pkg-config --libs glu`
+
+
+ # STEP 4: CHOOSE WHICH HARDWARE / OS YOU ARE RUNNING
+@@ -91,13 +91,11 @@
+
+ # STEP 7: CHOOSE ANY OPTIMIZATIONS OR ADD ANY SPECIAL INCLUSIONS
+ # ------------------------------------------------------------
+-CFLAGS = -O2 -I/usr/local/X11/include -I/usr/demo/SOUND/ -I./. $(AUDIODEF) $(OS)
+
+
+ # STEP 8: ADD ANY SPECIAL LIBRARY PATHS
+ # (USEFUL TO POINT TO WHERE THE MESA LIBRARIES RESIDE)
+ # ------------------------------------------------------------
+-LIBFLAGS =
+
+ # you should now be able to type 'make' and everything should be fine ...
+
+@@ -106,15 +104,16 @@
+ TARGET = battalion
+
+ OBJ = battalion.o audio.o net.o gprim.o graphics.o objects.o text.o update.o tk.o font.o soundIt.o
+-LIBS = -L./. -L/usr/X11R6/lib -lm -lX11 -lXext
++my_CPPFLAGS = -lm `pkg-config --cflags x11` `pkg-config --cflags xext` -I./. $(AUDIODEF) $(OS)
++my_LIBS = -lm `pkg-config --libs x11` `pkg-config --libs xext`
+
+ all: $(TARGET)
+
+-#$(OBJ): $(?:.o=.c)
+-# $(CC) $(CFLAGS) $(LIBFLAG) $(OS) $(WHICHLIB) $(AUDIOLIB) -c $?
++.c.o:
++ $(CC) $(CPPFLAGS) $(my_CPPFLAGS) $(CFLAGS) $(GLIB_CFLAGS) $(OS) $(WHICHLIB) $(AUDIOLIB) -c $<
+
+ $(TARGET): $(OBJ)
+- $(CC) -o $(TARGET) $(OBJ) $(LIBFLAGS) $(GLIB) $(LIBS) $(AUDIODEF)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(GLIB_LIBS) $(LIBS) $(my_LIBS) $(AUDIODEF)
+
+ clean:
+ rm -f $(OBJ)
diff --git a/games-action/battalion/files/battalion-1.4b-warning.patch b/games-action/battalion/files/battalion-1.4b-warning.patch
new file mode 100644
index 000000000000..91fd8ee51d3b
--- /dev/null
+++ b/games-action/battalion/files/battalion-1.4b-warning.patch
@@ -0,0 +1,12 @@
+diff -ru battalion1.4b.orig/net.c battalion1.4b/net.c
+--- battalion1.4b.orig/net.c 2002-05-06 09:57:01.000000000 -0400
++++ battalion1.4b/net.c 2015-03-30 18:29:23.885306334 -0400
+@@ -378,7 +378,7 @@
+
+ /* nother copy of this elsewhere */
+
+- sprintf(mesg, "%s %d %3.1f %3.1f %3.1f %3.1f %0.3f %d %d #", MESG_NEW_TANK,
++ sprintf(mesg, "%s %d %3.1f %3.1f %3.1f %3.1f %0.3f %d #", MESG_NEW_TANK,
+ tempTank->number,
+ tempTank->x-globalxshift,
+ tempTank->z-globalzshift,