summaryrefslogtreecommitdiff
path: root/games-action/bzflag/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/bzflag/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/bzflag/files')
-rw-r--r--games-action/bzflag/files/bzflag-2.4.12-configure.patch36
-rw-r--r--games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch19
-rw-r--r--games-action/bzflag/files/bzflag-2.4.12-tinfo.patch15
3 files changed, 70 insertions, 0 deletions
diff --git a/games-action/bzflag/files/bzflag-2.4.12-configure.patch b/games-action/bzflag/files/bzflag-2.4.12-configure.patch
new file mode 100644
index 000000000000..e1c546f37a34
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.12-configure.patch
@@ -0,0 +1,36 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -215,7 +215,7 @@
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+-AC_PATH_PROG(CCACHE, ccache)
++AC_PATH_PROG(CCACHE, ccachex)
+ if test "$CCACHE" ; then
+ CC="ccache $CC"
+ CXX="ccache $CXX"
+@@ -747,13 +747,13 @@
+ #
+ # the GCC version is known to be at least 4.3 because it has C++0x support
+ # possible future warnings: -Wconversion (1894) -Wfloat-equal (317)
+-FLAGS="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
++FLAGSx="-Wall -Wextra -Wcast-qual -Wredundant-decls -Wshadow -Wundef -pedantic"
+ case $host_os in
+ linux*)
+ AC_DEFINE(HALF_RATE_AUDIO, 1, [Half rate Audio])
+ CONF_CFLAGS="$CONF_CFLAGS $FLAGS"
+ CONF_CXXFLAGS="$CONF_CXXFLAGS $FLAGS"
+- case $host_vendor in
++ case $host_vendorx in
+ pc)
+ if expr `$CC -dumpversion` \>= "3.4" > /dev/null ; then
+ FLAGS=-mtune
+@@ -836,7 +836,7 @@
+ CXXFLAGS="$user_CXXFLAGS"
+ AC_DEFINE(DEBUG, 1, [Debugging enabled])
+ else
+- if test "$GCC" = yes ; then
++ if test "$GCC" = yesx ; then
+ case "`$CC --version 2>&1`" in
+ *LLVM*)
+ # Apple LLVM falsely claims to be GCC
diff --git a/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch b/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch
new file mode 100644
index 000000000000..f7f6dfd7f14c
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.12-sdl2-cppflags.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -236,6 +236,7 @@
+ AC_PROG_CC
+ AC_PROG_LN_S
+ AC_CHECK_PROG(AR, ar, ar)
++PKG_PROG_PKG_CONFIG
+ AC_SUBST(AR)
+ AC_SUBST(AR_FLAGS)
+
+@@ -716,6 +717,8 @@
+ fi
+ if test "x$with_SDL" = "x2"; then
+ AC_DEFINE(HAVE_SDL2, 1, [Using SDL2])
++ PKG_CHECK_MODULES(sdl2, sdl2,
++ [CONF_CPPFLAGS="$CONF_CPPFLAGS $sdl2_CFLAGS"],[])
+ fi
+
+ AM_CONDITIONAL(HAVE_SDL, test x$with_SDL = x1 -o x$with_SDL = x2)
diff --git a/games-action/bzflag/files/bzflag-2.4.12-tinfo.patch b/games-action/bzflag/files/bzflag-2.4.12-tinfo.patch
new file mode 100644
index 000000000000..aa43980b9b67
--- /dev/null
+++ b/games-action/bzflag/files/bzflag-2.4.12-tinfo.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -125,7 +125,11 @@
+ BZ_CONFIGURE_STAGE([arguments], [1 of 9])
+
+ # provide a with-curses option, test for curses
+-MP_WITH_CURSES
++PKG_CHECK_MODULES(ncurses, ncurses,
++ [CURSES_LIB="$ncurses_LIBS"]
++ AC_DEFINE(HAVE_NCURSES_H, , [Use the header file ncurses.h]),
++ AC_MSG_ERROR([Could not find ncurses]))
++AC_SUBST(CURSES_LIB)
+
+ # check for SDL option (enabled by default now)
+ AC_ARG_WITH(SDL, AS_HELP_STRING([--without-SDL | --with-SDL={1,2}],[Do not use Simple DirectMedia Layer or force using a specific version (by default tries 2, then 1, then resorts to native platform code if available]), sdl_version="$withval", sdl_version="detect")