summaryrefslogtreecommitdiff
path: root/games-action/crimsonland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /games-action/crimsonland
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'games-action/crimsonland')
-rw-r--r--games-action/crimsonland/Manifest3
-rw-r--r--games-action/crimsonland/crimsonland-1.3.5.ebuild48
-rw-r--r--games-action/crimsonland/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/games-action/crimsonland/Manifest b/games-action/crimsonland/Manifest
new file mode 100644
index 000000000000..90c2afa1c4ef
--- /dev/null
+++ b/games-action/crimsonland/Manifest
@@ -0,0 +1,3 @@
+DIST Crimsonland-Linux-x86-1.3.5.tar 58620320 BLAKE2B c67f132390e1a1b9a1697e877370f91603d558ddba717608a7f3709bb8395fe5017f598dfed82312f670ed510e4bb307df77978769776de184d5ce72d8792a6e SHA512 14faeeeba2326ece9a88b32442f5c65e3aec8c0a6e7a486a034d2684a8a6bb9059a25c574cc6d8cb798733e5ecd1db8ad25b610ec1d1177c4ec6493f02953e06
+EBUILD crimsonland-1.3.5.ebuild 1072 BLAKE2B 182afd23b7307caf2995bf739b4b0faa492a52d4e202c8992bb95e723972b92bf3546a2c0f2a553b4e2a7e992707bad2441e191f14c72d23395aab88784ee99c SHA512 f5151e7990f87205c7042496ce223d17b6204f6c9048e7072de92dd5f4a4f4b086d8dab87672992e1593f2855e6f54b2531a8b423eafaf5aafe572aefad0880c
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-action/crimsonland/crimsonland-1.3.5.ebuild b/games-action/crimsonland/crimsonland-1.3.5.ebuild
new file mode 100644
index 000000000000..e8809fadd77d
--- /dev/null
+++ b/games-action/crimsonland/crimsonland-1.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg-utils
+
+DESCRIPTION="A top-down shooter with a touch of RPG"
+HOMEPAGE="https://crimsonland.com/"
+SRC_URI="Crimsonland-Linux-x86-${PV}.tar"
+# https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe ${PN}
+ make_wrapper ${PN} ./${PN} "${DIR}"
+
+ insinto "${DIR}"
+ doins *.pak *.xml
+
+ dodoc README.txt
+
+# doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Crimsonland applications-games
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-action/crimsonland/metadata.xml b/games-action/crimsonland/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/crimsonland/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>