summaryrefslogtreecommitdiff
path: root/games-action/descent3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-action/descent3
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/descent3')
-rw-r--r--games-action/descent3/Manifest4
-rw-r--r--games-action/descent3/descent3-1.4.0b-r2.ebuild101
-rw-r--r--games-action/descent3/metadata.xml11
3 files changed, 0 insertions, 116 deletions
diff --git a/games-action/descent3/Manifest b/games-action/descent3/Manifest
deleted file mode 100644
index d9c208619dfa..000000000000
--- a/games-action/descent3/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST descent3-1.4.0a-x86.run 2736956 BLAKE2B 23ea2042404308ff6d9b1b3fca688b1b59c9a774017ed0ca0a1e95166c698a41f7453addf6af043bb5faed8866ce590692dc8c708de01fb5464b0c456863c50e SHA512 e6c5d6a678c46374c5d5d40589d40906378fd17ebb658778a2d052a71cd069877a43eb83b344b41473fe443e886c3b07283ea9de908df4ab8584638670114ecc
-DIST descent3-1.4.0b-x86.run 4504631 BLAKE2B e6e807b8e1bc511a612a7b217ec9b86bb75cebfee3b30f636f7b668a651c09e61b13679d332e92708e8adc926033c4abe9b270e0357673d4026f934f31287de2 SHA512 912afcf51a2f4f8cacb231e318d4837c64b2f762109244c083760b5e580298d4166fea0878ee2d344b841c788d673896a09d0052ebea59dead637d834e826db3
-EBUILD descent3-1.4.0b-r2.ebuild 2648 BLAKE2B 081a45cb4d741de3d086fda9f32425d3e14385ec5c2ac96e8608a41cf35d6fef6e9c696c9f51329d2ef1a38f8d0012f6ce2a379f2639634dcec1954f0e340a1d SHA512 3c7aff0955aeac46ae72f89b993b78922a5450dce9f5d7270a42461c32cefef4795b48eddcae13405d4f35c71fd27adecfc922dfedfdff2a2773f0c364f37566
-MISC metadata.xml 625 BLAKE2B 5fd68ba049724b77f21760b68d7a2a755dbf7b8caa159d629cd19bac4c7500b02a867bd999d87cafa96f2895ab068c1ae37890021f2de1be52a377dde4f4ac20 SHA512 a72428b67ed26503112a398643a53230dd80f0b48a0ffa53a4ade00647302147aa042acc91cc6b49fef0d23efeafef2e33d4caea4bb845de7f6d08e8c943d71c
diff --git a/games-action/descent3/descent3-1.4.0b-r2.ebuild b/games-action/descent3/descent3-1.4.0b-r2.ebuild
deleted file mode 100644
index d663b28ab8f5..000000000000
--- a/games-action/descent3/descent3-1.4.0b-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils unpacker cdrom multilib games
-
-IUSE="nocd videos"
-DESCRIPTION="Descent 3 - 3-Dimensional indoor/outdoor spaceship combat"
-HOMEPAGE="http://www.lokigames.com/products/descent3/"
-SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
- mirror://lokigames/${PN}/${P}-x86.run"
-
-LICENSE="LOKI-EULA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="strip"
-
-RDEPEND="sys-libs/glibc
- media-libs/libsdl[abi_x86_32(-)]
- media-libs/smpeg[abi_x86_32(-)]
- virtual/opengl[abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]"
-
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
-
-pkg_setup() {
- games_pkg_setup
- if use videos ; then
- ewarn "The installed game takes about 1.2GB of space!"
- elif use nocd ; then
- ewarn "The installed game takes about 510MB of space!"
- else
- ewarn "The installed game takes about 220MB of space!"
- fi
-}
-
-src_unpack() {
- if use videos ; then
- cdrom_get_cds missions/d3.mn3 movies/level1.mve
- else
- cdrom_get_cds missions/d3.mn3
- fi
- mkdir -p "${S}"/{a,b} || die
- cd "${S}"/a || die
- unpack_makeself ${PN}-1.4.0a-x86.run
- cd "${S}"/b || die
- unpack_makeself ${P}-x86.run
-}
-
-src_install() {
- einfo "Copying files... this may take a while..."
- exeinto "${dir}"
- doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{${PN},nettest}
- insinto "${dir}"
- doins ${CDROM_ROOT}/{FAQ.txt,README{,.mercenary},d3.hog,icon.{bmp,xpm}}
-
- cd "${Ddir}" || die
- # TODO: move this to src_unpack where it belongs
- tar xzf ${CDROM_ROOT}/data.tar.gz || die
- tar xzf ${CDROM_ROOT}/shared.tar.gz || die
-
- if use nocd; then
- doins -r ${CDROM_ROOT}/missions
- fi
-
- if use videos ; then
- cdrom_load_next_cd
- doins -r ${CDROM_ROOT}/movies
- fi
-
- cd "${S}"/a || die
- bin/Linux/x86/loki_patch --verify patch.dat || die
- bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
- cd "${S}"/b || die
- bin/Linux/x86/loki_patch --verify patch.dat || die
- bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
-
- # now, since these files are coming off a cd, the times/sizes/md5sums wont
- # be different ... that means portage will try to unmerge some files (!)
- # we run touch on ${D} so as to make sure portage doesnt do any such thing
- find "${Ddir}" -exec touch '{}' +
-
- games_make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
- newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
-
- # Fix for 2.6 kernel crash
- cd "${Ddir}" || die
- ln -sf ppics.hog PPics.Hog
-
- prepgamesdirs
- make_desktop_entry ${PN} "Descent 3" ${PN}
-}
-
-pkg_postinst() {
- games_pkg_postinst
- elog "To play the game run:"
- elog " descent3"
- echo
-}
diff --git a/games-action/descent3/metadata.xml b/games-action/descent3/metadata.xml
deleted file mode 100644
index bdbb1bdaaee9..000000000000
--- a/games-action/descent3/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-<longdescription>
-Descent 3 is a first-person 3-D action flight-sim which takes place in both indoor and outdoor arenas. The game was ported to Linux by the now defunct Loki Entertainment and is commercial software. You can still pick up a copy from Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher is no longer in business.
-</longdescription>
-</pkgmetadata>