summaryrefslogtreecommitdiff
path: root/games-action/heroes/heroes-0.21-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /games-action/heroes/heroes-0.21-r3.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'games-action/heroes/heroes-0.21-r3.ebuild')
-rw-r--r--games-action/heroes/heroes-0.21-r3.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/games-action/heroes/heroes-0.21-r3.ebuild b/games-action/heroes/heroes-0.21-r3.ebuild
new file mode 100644
index 000000000000..502043e2eb33
--- /dev/null
+++ b/games-action/heroes/heroes-0.21-r3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="Heroes Enjoy Riding Over Empty Slabs: similar to Tron and Nibbles"
+HOMEPAGE="http://heroes.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-data-1.5.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-sound-tracks-1.0.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-sound-effects-1.0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ggi nls +sdl"
+REQUIRED_USE="^^ ( ggi sdl )"
+RESTRICT="test"
+
+RDEPEND="
+ ggi? (
+ media-libs/libggi
+ media-libs/libgii
+ media-libs/libmikmod
+ )
+ nls? ( virtual/libintl )
+ sdl? (
+ media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-mixer[mod]
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-gcc4.patch
+ "${FILESDIR}"/${P}-cvs-segfault-fix.patch
+ "${FILESDIR}"/${P}-compilation.patch
+ "${FILESDIR}"/${P}-gcc10.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable nls)
+ $(use_with ggi mikmod)
+ $(use_with ggi)
+ $(use_with sdl sdl-mixer)
+ $(use_with sdl)
+ --disable-heroes-debug
+ --disable-optimizations
+ )
+
+ local pkg
+ for pkg in ${A//.tar.bz2}; do
+ cd "${WORKDIR}"/${pkg} || die
+ econf "${econfargs[@]}"
+ done
+}
+
+src_install() {
+ local pkg
+ for pkg in ${A//.tar.bz2} ; do
+ emake -C "${WORKDIR}"/${pkg} DESTDIR="${D}" install
+ done
+
+ einstalldocs
+
+ make_desktop_entry ${PN} Heroes applications-games
+}