summaryrefslogtreecommitdiff
path: root/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild')
-rw-r--r--games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild b/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
new file mode 100644
index 000000000000..22373707aea9
--- /dev/null
+++ b/games-action/moon-buggy/moon-buggy-1.0.51-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils user
+
+DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
+HOMEPAGE="http://www.seehuhn.de/comp/moon-buggy.html"
+SRC_URI="http://www.seehuhn.de/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/$(DESTDIR)$(bindir)\/moon-buggy -c/d' \
+ Makefile.am || die
+ rm -f missing
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sharedstatedir="/var/games" \
+ --with-curses-libs="$(pkg-config ncurses --libs)"
+}
+
+src_install() {
+ default
+ touch "${D}/var/games/${PN}/mbscore"
+ fowners root:gamestat /usr/bin/${PN} /var/games/${PN} /var/games/${PN}/mbscore
+ fperms 2755 /usr/bin/${PN}
+ fperms 664 /var/games/${PN}/mbscore
+}