summaryrefslogtreecommitdiff
path: root/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'games-action/openastromenace/openastromenace-1.3.2-r1.ebuild')
-rw-r--r--games-action/openastromenace/openastromenace-1.3.2-r1.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild b/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
deleted file mode 100644
index 55f86bda67a7..000000000000
--- a/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils desktop gnome2-utils
-
-DESCRIPTION="Modern 3D space shooter with spaceship upgrade possibilities"
-HOMEPAGE="https://sourceforge.net/projects/openastromenace/"
-SRC_URI="mirror://sourceforge/openastromenace/${PV}/astromenace-src-${PV}.tar.bz2"
-
-LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 UbuntuFontLicense-1.0 OFL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- media-libs/freealut
- media-libs/freetype:2
- media-libs/libogg
- media-libs/libsdl[joystick,video,X]
- media-libs/libvorbis
- media-libs/openal
- virtual/glu
- virtual/opengl
- x11-libs/libXinerama"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/AstroMenace
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # no messing with CXXFLAGS please.
- sed -i -e '/-Os/d' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=("-DDATADIR=/usr/share/${PN}")
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- "${CMAKE_BUILD_DIR}"/AstroMenace --pack \
- --rawdata="${S}"/RAW_VFS_DATA \
- --dir=$(dirname "${CMAKE_BUILD_DIR}") || die
-}
-
-src_install() {
- newbin "${CMAKE_BUILD_DIR}"/AstroMenace "${PN}"
-
- insinto /usr/share/${PN}
- doins ../*.vfs
-
- newicon -s 128 astromenace_128.png ${PN}.png
- newicon -s 64 astromenace_64.png ${PN}.png
-
- dodoc ChangeLog.txt ReadMe.txt
-
- make_desktop_entry "${PN}" OpenAstroMenace
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}