summaryrefslogtreecommitdiff
path: root/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /games-action/shootingstar/shootingstar-1.2.0-r2.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'games-action/shootingstar/shootingstar-1.2.0-r2.ebuild')
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild b/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..7885724a6b03
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop toolchain-funcs
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[opengl,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-basic-fixes.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newicon data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
+}