summaryrefslogtreecommitdiff
path: root/games-action/xbomber/xbomber-101-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/xbomber/xbomber-101-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/xbomber/xbomber-101-r1.ebuild')
-rw-r--r--games-action/xbomber/xbomber-101-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-action/xbomber/xbomber-101-r1.ebuild b/games-action/xbomber/xbomber-101-r1.ebuild
new file mode 100644
index 000000000000..2757b322f5db
--- /dev/null
+++ b/games-action/xbomber/xbomber-101-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Bomberman clone w/multiplayer support"
+HOMEPAGE="http://www.xdr.com/dash/bomber.html"
+SRC_URI="http://www.xdr.com/dash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="!sci-biology/emboss
+ ${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-va_list.patch
+ "${FILESDIR}"/${P}-gcc4.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e "/^CC/d" \
+ -e 's/gcc/$(CC)/g' \
+ -e "s:X386:X11R6:" \
+ Makefile || die
+
+ # ${P}-ldflags.patch depends on the munged Makefile
+ default
+
+ sed -i \
+ -e "s:data/%s:/usr/share/${PN}/%s:" bomber.c || die
+ sed -i \
+ -e "s:=\"data\":=\"/usr/share/${PN}\":" sound.c || die
+}
+
+src_install() {
+ dobin matcher bomber
+ insinto /usr/share/${PN}
+ doins -r data/*
+ dodoc README Changelog
+}