summaryrefslogtreecommitdiff
path: root/games-action/xpilot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/xpilot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/xpilot')
-rw-r--r--games-action/xpilot/Manifest3
-rw-r--r--games-action/xpilot/metadata.xml11
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild54
3 files changed, 68 insertions, 0 deletions
diff --git a/games-action/xpilot/Manifest b/games-action/xpilot/Manifest
new file mode 100644
index 000000000000..78900ee9abb3
--- /dev/null
+++ b/games-action/xpilot/Manifest
@@ -0,0 +1,3 @@
+DIST xpilot-4.5.5.tar.bz2 1115502 BLAKE2B 9f7758dabc834f9ffad602e2ba215e1e08ff3f33b21480eae0176775d6c55df3e3238652e0cbbbc688acbab9e23395f46d853ee52fd55d177fdace5138621335 SHA512 002fbdbee3035e21f441d749d68ac41da2816a691e1c0d1cf9de9cddaa479c92da57eb36081884b9908a6ae83454f6f532c24c89280d27e2cbf9570442ef301c
+EBUILD xpilot-4.5.5-r1.ebuild 1174 BLAKE2B 4d3a4f23c68eb9d92dcee083a3df857240a97a8b87d04da9f68541e12148cb6faf52f3a12658d94df4ed592ec9f88fa7afcc968d7e216871819b16a0eb6dd857 SHA512 b4ab6b1b30754d099b6ba9fbf3e37cc1146ba46095eb0c9a60da45f2516aa3d89cdcb9666be6fa5ada2b8910715d9d7f8470f4bec13b42fc8fad71dc02bcf01c
+MISC metadata.xml 333 BLAKE2B 2c8f9dc52fcf4780ad3da4ee828dad3ef62731f0d2f399da8ade242756b6929a58a6b60347ed753f19dbbf6cf2146dadeb88fa20be6d035ae3fc41ca581bacdb SHA512 b6a52a4afe7804b04646d42366ef3812a70fba44d44e9da662a70c7c646aba015792fd8bef65da9c5abdc4b5188cf0657ba80ab1d1920b6b692606274c3afca4
diff --git a/games-action/xpilot/metadata.xml b/games-action/xpilot/metadata.xml
new file mode 100644
index 000000000000..8276088f013b
--- /dev/null
+++ b/games-action/xpilot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">xpilotgame</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
new file mode 100644
index 000000000000..ecc92dce8706
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-base/xorg-proto
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_prepare() {
+ #default
+ eapply_user
+
+ sed -i \
+ -e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
+ -e "/^INSTLIB/s:=.*:=/usr/share/${PN}:" \
+ -e "/^INSTBIN/s:=.*:=/usr/bin:" \
+ Local.config || die
+
+ # work with glibc-2.20
+ sed -i \
+ -e 's/getline/lgetline/' \
+ src/client/textinterface.c || die
+}
+
+src_compile() {
+ xmkmf || die
+ emake Makefiles
+ emake includes
+ emake depend
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install.man
+ newicon lib/textures/logo.ppm ${PN}.ppm
+ make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
+ dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+}