summaryrefslogtreecommitdiff
path: root/games-arcade/amphetamine/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/amphetamine/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/amphetamine/files')
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch72
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-bugs.patch56
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch33
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-missing-headers.patch13
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-newline.patch358
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-no-lxt.patch14
6 files changed, 546 insertions, 0 deletions
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch
new file mode 100644
index 000000000000..b7588face714
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch
@@ -0,0 +1,72 @@
+--- amphetamine-0.8.10.orig/src/Shape.cpp
++++ amphetamine-0.8.10/src/Shape.cpp
+@@ -56,12 +56,12 @@
+ */
+ #ifdef __OPT_MEM_ACCESS__
+
+-#define GET_LONG(adr) *(unsigned long *)adr
+-#define SET_LONG(adr, l) *(unsigned long *)adr = l
++#define GET_LONG(adr) *(uint32_t *)adr
++#define SET_LONG(adr, l) *(uint32_t *)adr = l
+
+ #else
+
+-#define GET_LONG(adr) ((long)((unsigned char *)(adr))[0] << 24) + ((long)((unsigned char *)(adr))[1] << 16) + ((long)((unsigned char *)(adr))[2] << 8) + ((long)((unsigned char *)(adr))[3])
++#define GET_LONG(adr) ((uint32_t)((unsigned char *)(adr))[0] << 24) + ((uint32_t)((unsigned char *)(adr))[1] << 16) + ((uint32_t)((unsigned char *)(adr))[2] << 8) + ((uint32_t)((unsigned char *)(adr))[3])
+ #define SET_LONG(adr, l) ((unsigned char *)adr)[0] = (unsigned char)((l) >> 24); \
+ ((unsigned char *)adr)[1] = (unsigned char)((l) >> 16); \
+ ((unsigned char *)adr)[2] = (unsigned char)((l) >> 8); \
+@@ -116,7 +116,7 @@
+ {
+ // store the location of this line start
+ lineStartPtr = destPtr;
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+
+ // at the beginning of each row we are not in any run
+ drawRunFlag = kFalse;
+@@ -160,7 +160,7 @@
+ // create the skip token
+ //*( ( unsigned long * )destPtr ) = ( kSkipPixelsToken << 24 ) + runCounter;
+ SET_LONG(destPtr, ( kSkipPixelsToken << 24 ) + runCounter);
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+ }
+
+ // are we in a draw run
+@@ -179,7 +179,7 @@
+
+ // save the location of the token (so we can fill it in later)
+ runTokenPtr = destPtr;
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+
+ // copy the pixel
+ *destPtr = *srcPtr;
+@@ -215,7 +215,7 @@
+
+ // create the end of shape token
+ SET_LONG(destPtr, kEndShapeToken << 24);
+- destPtr += sizeof( unsigned long );
++ destPtr += sizeof( uint32_t );
+
+ // Resize the handle to match the real size of the shape
+ //SetHandleSize( shapeHandle, destPtr - ( unsigned char * )( *shapeHandle ) );
+@@ -280,7 +280,7 @@
+ // get a token
+ tokenOp = GET_LONG(srcPtr ) >> 24;
+ tokenData = GET_LONG(srcPtr ) & 0x00ffffff;
+- srcPtr += sizeof( unsigned long );
++ srcPtr += sizeof( uint32_t );
+
+ // depending on the token
+ switch( tokenOp )
+@@ -435,7 +435,7 @@
+ // get a token
+ tokenOp = GET_LONG(srcPtr) >> 24;
+ tokenData = GET_LONG(srcPtr) & 0x00ffffff;
+- srcPtr += sizeof( unsigned long );
++ srcPtr += sizeof( uint32_t );
+
+ // depending on the token
+ switch( tokenOp )
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-bugs.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-bugs.patch
new file mode 100644
index 000000000000..40a8345516c5
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-bugs.patch
@@ -0,0 +1,56 @@
+description: fix issues in collision detection
+Index: amphetamine-0.8.10/src/Appl.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Appl.cpp 2006-05-15 19:16:56.000000000 +0200
++++ amphetamine-0.8.10/src/Appl.cpp 2006-05-15 19:17:02.000000000 +0200
+@@ -183,7 +183,7 @@
+
+ firstPlayRound = 1;
+ command = kCmdNoCommand;
+- syncTime = gSystem->GetTicks();
++ syncTime = gSystem->GetTicks() - 20;
+ aveTime = 20;
+
+ while (command == kCmdNoCommand) {
+@@ -256,7 +256,7 @@
+
+ if (gSystem->KeyPressed(kKeyEscape)) {
+ command = gGUI->RunUserInterface(kMainPage);
+- syncTime = gSystem->GetTicks();
++ syncTime = gSystem->GetTicks() - aveTime;
+ }
+
+ if (command >= kSaveGameSlot0 && command <= kSaveGameSlot5) {
+Index: amphetamine-0.8.10/src/Object.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Object.cpp 2006-05-15 19:18:21.000000000 +0200
++++ amphetamine-0.8.10/src/Object.cpp 2006-05-15 19:18:33.000000000 +0200
+@@ -70,10 +70,13 @@
+ {
+ if (ABS(forcex) > ABS(forcey)) {
+ sx += SIGN(forcex);
+- sy += forcey / ABS(forcex);
++ if (forcex != 0)
++ sy += forcey / ABS(forcex);
+ }else{
+ sy += SIGN(forcey);
+- sx += forcex / ABS(forcey);
++ /* Avoid SIGFE on alpha on divide by zero. -- JEH */
++ if (forcey != 0)
++ sx += forcex / ABS(forcey);
+ }
+ }
+
+Index: amphetamine-0.8.10/src/Pltform.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Pltform.cpp 2006-05-15 19:18:25.000000000 +0200
++++ amphetamine-0.8.10/src/Pltform.cpp 2006-05-15 19:18:33.000000000 +0200
+@@ -136,7 +136,7 @@
+
+ short CPlatform::Forces()
+ {
+- short collisionObject, collisionCode;
++ short collisionObject = 0, collisionCode;
+ CObject *collObj;
+
+ CObject::Forces();
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch
new file mode 100644
index 000000000000..185826c35c37
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-build.patch
@@ -0,0 +1,33 @@
+--- a/Makefile
++++ b/Makefile
+@@ -26,8 +26,8 @@
+
+ # makemake variables
+
+-LINKER := g++
+-DEPENDFLAGS := -g ${SEARCHDIRS}
++LINKER = $(CXX) $(CXXFLAGS)
++DEPENDFLAGS := ${SEARCHDIRS}
+ TOUCHHEADERS := ${MYCODEDIR}/*.h
+
+ # C
+@@ -37,8 +37,8 @@
+
+ # C++
+
+-CXX := g++
+-CXXFLAGS = ${DEPENDFLAGS} -O9 -funroll-loops -fomit-frame-pointer -ffast-math -Wcast-align
++CXX ?= g++
++CXXFLAGS += ${DEPENDFLAGS}
+
+ %.o : %.cpp
+ ${CXX} ${CPPFLAGS} -c $< ${CXXFLAGS} -o $@
+@@ -66,7 +66,7 @@
+ LOADLIBES := $(LOADLIBES) -lXpm -lXt
+ endif
+
+-LDFLAGS = -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
++LDFLAGS += -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
+
+ .PHONY : default
+ default : amph
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-missing-headers.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-missing-headers.patch
new file mode 100644
index 000000000000..f9c1b9932b11
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-missing-headers.patch
@@ -0,0 +1,13 @@
+description: include string.h
+Index: amphetamine-0.8.10/src/Surface.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Surface.cpp 2006-05-15 19:10:49.000000000 +0200
++++ amphetamine-0.8.10/src/Surface.cpp 2006-05-15 19:11:01.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include "ShapeLd.hpp"
+ #include "Clut.hpp"
+ #include "ConstVal.hpp"
++#include <string.h>
+ #include <memory.h>
+
+ const short kNoCharSpace = 20;
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-newline.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-newline.patch
new file mode 100644
index 000000000000..36482ef30fb1
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-newline.patch
@@ -0,0 +1,358 @@
+description: fix newlines
+Index: amphetamine-0.8.10/src/AmpHead.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/AmpHead.hpp 2002-03-25 11:38:15.000000000 +0100
++++ amphetamine-0.8.10/src/AmpHead.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -185,4 +185,4 @@
+
+ #define MSG(message) if (logFile) fprintf(logFile, message); fflush(logFile)
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Appl.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Appl.cpp 2002-03-25 12:47:49.000000000 +0100
++++ amphetamine-0.8.10/src/Appl.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -404,4 +404,4 @@
+ if (preRenderQueue == remove) bulletList = bulletList->nextBullet;
+ if (remove->nextBullet) remove->nextBullet->prevBullet = remove->prevBullet;
+ if (remove->prevBullet) remove->prevBullet->nextBullet = remove->nextBullet;
+-}*/
+\ No newline at end of file
++}*/
+Index: amphetamine-0.8.10/src/Appl.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Appl.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Appl.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -102,4 +102,4 @@
+
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Clut.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Clut.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Clut.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -84,4 +84,4 @@
+
+ void SwapBlackWhite(Graphic_file *gf);
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/ConstVal.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/ConstVal.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/ConstVal.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -271,4 +271,5 @@
+ void GetStringConstant(FILE *f, char *constName, char *buffer)
+ {
+ GetValue(f, constName, buffer);
+-}
+\ No newline at end of file
++}
++
+Index: amphetamine-0.8.10/src/ConstVal.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/ConstVal.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/ConstVal.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -160,4 +160,4 @@
+ short disableShapeModes;
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Creeper.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Creeper.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Creeper.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -4,4 +4,4 @@
+ #include "Monster.hpp"
+
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Element.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Element.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Element.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -373,4 +373,4 @@
+ CElement::Read(f);
+
+ OnAllocate();
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/File.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/File.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/File.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -26,4 +26,4 @@
+ long CFile::ReadData(void *data, long size)
+ {
+ return fread(data, size, 1, fileRef);
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/Graphfil.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Graphfil.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Graphfil.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -54,4 +54,4 @@
+ Graphic_file *LoadGIF(FILE *fp, char *fname );
+ Graphic_file *LoadPICTR(FILE *fp, char *fname );
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Gui.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Gui.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Gui.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -796,4 +796,5 @@
+ fclose(f);
+ }
+
+-
+\ No newline at end of file
++
++
+Index: amphetamine-0.8.10/src/Gui.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Gui.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Gui.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -183,4 +183,4 @@
+ void DisplayInfotext(short num);
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Item.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Item.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Item.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -309,4 +309,4 @@
+
+ READDATA(pickedUp);
+ READDATA(type);
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/Item.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Item.hpp 2002-03-24 11:10:24.000000000 +0100
++++ amphetamine-0.8.10/src/Item.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -84,4 +84,4 @@
+ void Read(FILE *f);
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Level.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Level.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Level.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -29,4 +29,4 @@
+ };
+
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Main.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Main.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Main.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -84,4 +84,4 @@
+ delete gApplication;
+
+ return 0;
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/Monster.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Monster.cpp 2002-03-25 11:53:27.000000000 +0100
++++ amphetamine-0.8.10/src/Monster.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -372,4 +372,4 @@
+ READDATA(health);
+
+ if (dieFrame != -1) gApplication->Dequeue(&gApplication->collisionThingList, this);
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/Monster.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Monster.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Monster.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -86,4 +86,4 @@
+
+
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Monstrxx.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Monstrxx.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Monstrxx.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -123,4 +123,4 @@
+ void Read(FILE *f);
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/ObjInfo.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/ObjInfo.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/ObjInfo.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -97,4 +97,4 @@
+ tWeaponInfo *FindWeapon(short ref);
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Player.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Player.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Player.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -527,4 +527,4 @@
+
+ READDATA(oxygen);
+ READDATA(lastOxygenDecTime);
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/Player.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Player.hpp 2002-03-24 11:10:24.000000000 +0100
++++ amphetamine-0.8.10/src/Player.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -81,4 +81,4 @@
+
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Pltform.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Pltform.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Pltform.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -276,4 +276,4 @@
+ fread(info, sizeof(tPlatformInfo), 1, f);
+
+ OnAllocate();
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/ShapeDes.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/ShapeDes.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/ShapeDes.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -376,4 +376,4 @@
+ };
+
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/ShapeLd.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/ShapeLd.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/ShapeLd.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -93,4 +93,4 @@
+ height = backgroundPicture->height;
+
+ return backgroundPicture->bitmap;
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/SndSys.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/SndSys.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/SndSys.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -132,4 +132,5 @@
+ playList->RemoveCurrent();
+ }
+ }
+-}
+\ No newline at end of file
++}
++
+Index: amphetamine-0.8.10/src/SndSys.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/SndSys.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/SndSys.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -99,4 +99,5 @@
+
+ };
+
+-#endif
+\ No newline at end of file
++#endif
++
+Index: amphetamine-0.8.10/src/SoundList.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/SoundList.hpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/SoundList.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -55,4 +55,4 @@
+ SoundState *first, *prev, *current;
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/System.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/System.cpp 2002-03-25 10:31:27.000000000 +0100
++++ amphetamine-0.8.10/src/System.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -554,4 +554,5 @@
+ delete [] tmp;
+
+ return NULL; // failed
+-}
+\ No newline at end of file
++}
++
+Index: amphetamine-0.8.10/src/Thing.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Thing.hpp 2002-03-24 17:16:00.000000000 +0100
++++ amphetamine-0.8.10/src/Thing.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -64,4 +64,4 @@
+
+ };
+
+-#endif
+\ No newline at end of file
++#endif
+Index: amphetamine-0.8.10/src/Weapon.cpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Weapon.cpp 2002-03-24 09:49:09.000000000 +0100
++++ amphetamine-0.8.10/src/Weapon.cpp 2006-05-15 19:08:52.000000000 +0200
+@@ -467,4 +467,4 @@
+ READDATA(dx);
+ READDATA(dy);
+
+-}
+\ No newline at end of file
++}
+Index: amphetamine-0.8.10/src/Weapon.hpp
+===================================================================
+--- amphetamine-0.8.10.orig/src/Weapon.hpp 2002-03-24 17:16:14.000000000 +0100
++++ amphetamine-0.8.10/src/Weapon.hpp 2006-05-15 19:08:52.000000000 +0200
+@@ -152,4 +152,4 @@
+ short Shoot(double directionx, double directiony, double targetpos);
+ };
+
+-#endif
+\ No newline at end of file
++#endif
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-no-lxt.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-no-lxt.patch
new file mode 100644
index 000000000000..1e654dc89203
--- /dev/null
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-no-lxt.patch
@@ -0,0 +1,14 @@
+description: don't link against Xt
+Index: amphetamine-0.8.10/Makefile
+===================================================================
+--- amphetamine-0.8.10.orig/Makefile 2006-11-08 11:05:57.000000000 +0100
++++ amphetamine-0.8.10/Makefile 2006-11-08 11:06:01.000000000 +0100
+@@ -69,7 +69,7 @@
+ LOADLIBES := -lm $(SDL_LIBS)
+
+ ifeq ($(USE_LIB_XPM),TRUE)
+- LOADLIBES := $(LOADLIBES) -lXpm -lXt
++ LOADLIBES := $(LOADLIBES) -lXpm
+ endif
+
+ LDFLAGS = -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib