summaryrefslogtreecommitdiff
path: root/games-arcade/asteroid/asteroid-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /games-arcade/asteroid/asteroid-1.2.1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'games-arcade/asteroid/asteroid-1.2.1.ebuild')
-rw-r--r--games-arcade/asteroid/asteroid-1.2.1.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/games-arcade/asteroid/asteroid-1.2.1.ebuild b/games-arcade/asteroid/asteroid-1.2.1.ebuild
index 0272ee41549e..0f9fb6cd0973 100644
--- a/games-arcade/asteroid/asteroid-1.2.1.ebuild
+++ b/games-arcade/asteroid/asteroid-1.2.1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
-DESCRIPTION="A modern version of the arcade classic that uses OpenGL"
+inherit cmake
+
+DESCRIPTION="Modern version of the arcade classic that uses OpenGL"
HOMEPAGE="https://chazomaticus.github.io/asteroid/"
SRC_URI="https://github.com/chazomaticus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -14,13 +15,20 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
- virtual/opengl
media-libs/freeglut
- virtual/glu
media-libs/libsdl
media-libs/sdl-mixer
+ virtual/glu
+ virtual/opengl
x11-libs/gtk+:2
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-libm.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DOpenGL_GL_PREFERENCE=GLVND
+ )
+ cmake_src_configure
+}