summaryrefslogtreecommitdiff
path: root/games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 05:39:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 05:39:40 +0000
commitb24782302154e447b59c3f719970f951cd15cd38 (patch)
tree463a954988b9099fbc02967de0cf25b250d0caf7 /games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild
parent753ad9170f0d68e7f525f1931bc6ebf359268b29 (diff)
gentoo auto-resync : 19:02:2024 - 05:39:40
Diffstat (limited to 'games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild')
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild
new file mode 100644
index 000000000000..45e3f8fbcc15
--- /dev/null
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Classic overhead run-and-gun game"
+HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
+SRC_URI="
+ https://github.com/cxong/cdogs-sdl/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="
+ GPL-2+
+ BSD-2 CC-BY-3.0 CC-BY-4.0 CC-BY-SA-3.0 CC0-1.0 WTFPL-2 XMAME public-domain
+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl2[haptic,opengl]
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[mp3,vorbis,wav]
+ net-libs/enet:1.3=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.1-cmake.patch
+)
+
+src_configure() {
+ filter-lto #858527
+
+ local mycmakeargs=(
+ -DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/ # trailing / is needed
+ -DBUILD_EDITOR=OFF
+ -DUSE_SHARED_ENET=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc doc/{AUTHORS,original_readme.txt}
+
+ # CREDITS is used at runtime, rest is licenses or duplicates
+ find "${ED}"/usr/share/${PN}/doc -type f ! -name CREDITS -delete || die
+}