summaryrefslogtreecommitdiff
path: root/games-arcade/cdogs-sdl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /games-arcade/cdogs-sdl/files
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'games-arcade/cdogs-sdl/files')
-rw-r--r--games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Add-BUILD_EDITOR-option.patch89
-rw-r--r--games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Remove-Winline-and-Werror-definitions.patch24
2 files changed, 0 insertions, 113 deletions
diff --git a/games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Add-BUILD_EDITOR-option.patch b/games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Add-BUILD_EDITOR-option.patch
deleted file mode 100644
index 5a5912e9b3af..000000000000
--- a/games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Add-BUILD_EDITOR-option.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From f8adfb66ea686366edddc89e92c9a5537b8dfbef Mon Sep 17 00:00:00 2001
-From: William Breathitt Gray <vilhelm.gray@gmail.com>
-Date: Wed, 9 Dec 2020 07:45:54 -0500
-Subject: [PATCH] Add BUILD_EDITOR option to control cdogs-sdl-editor build
-
----
- CMakeLists.txt | 10 +++++++---
- src/CMakeLists.txt | 6 +++---
- 2 files changed, 10 insertions(+), 6 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 169a17ca..510e4802 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -29,12 +29,14 @@ SET(WEBSITE "http://cxong.github.io/cdogs-sdl/")
- option(DEBUG "Enable debug build" OFF)
- option(DEBUG_PROFILE "Enable debug profile build" OFF)
- option(USE_SHARED_ENET "Use system installed copy of enet" OFF)
-+option(BUILD_EDITOR "Build cdogs-sdl-editor" ON)
-
- # check for crosscompiling (defined when using a toolchain file)
- if(CMAKE_CROSSCOMPILING)
- # check for gcw0
- if(CMAKE_C_COMPILER MATCHES ".*gcw0-linux.*")
- set(GCW0 1)
-+ set(BUILD_EDITOR OFF)
- endif()
- endif()
-
-@@ -65,7 +67,9 @@ find_package(Nanopb REQUIRED)
- find_package(SDL2 REQUIRED)
- find_package(SDL2_image REQUIRED)
- find_package(SDL2_mixer REQUIRED)
--find_package(OpenGL REQUIRED)
-+if(BUILD_EDITOR)
-+ find_package(OpenGL REQUIRED)
-+endif()
- find_package(CCache)
- link_directories(${SDL2_LIBRARY_DIRS} ${SDL2_IMAGE_LIBRARY_DIRS} ${SDL2_MIXER_LIBRARY_DIRS})
-
-@@ -165,7 +169,7 @@ set_target_properties(cdogs-sdl PROPERTIES
- RUNTIME_OUTPUT_DIRECTORY_DEBUG ${CMAKE_CURRENT_BINARY_DIR}/src
- RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_CURRENT_BINARY_DIR}/src
- )
--if(NOT "${GCW0}")
-+if(BUILD_EDITOR)
- set_target_properties(cdogs-sdl-editor PROPERTIES
- RUNTIME_OUTPUT_DIRECTORY_DEBUG ${CMAKE_CURRENT_BINARY_DIR}/src
- RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_CURRENT_BINARY_DIR}/src
-@@ -200,7 +204,7 @@ install(
- PROGRAMS
- ${CMAKE_CURRENT_BINARY_DIR}/src/cdogs-sdl${EXE_EXTENSION}
- DESTINATION ${CDOGS_BIN_DIR})
--if(NOT "${GCW0}")
-+if(BUILD_EDITOR)
- install(
- PROGRAMS
- ${CMAKE_CURRENT_BINARY_DIR}/src/cdogs-sdl-editor${EXE_EXTENSION}
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 8fb82667..564cbf3f 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -4,12 +4,12 @@ include_directories(
- ${SDL2_INCLUDE_DIRS}
- ${SDL2_IMAGE_INCLUDE_DIRS}
- ${SDL2_MIXER_INCLUDE_DIRS})
--if(NOT "${GCW0}")
-+if(BUILD_EDITOR)
- include_directories(${OPENGL_INCLUDE_DIRS})
- endif()
-
- add_subdirectory(cdogs)
--if(NOT "${GCW0}")
-+if(BUILD_EDITOR)
- add_subdirectory(cdogsed)
- endif()
- add_subdirectory(json)
-@@ -82,7 +82,7 @@ if(GCW0)
- )
- endif()
-
--if(NOT "${GCW0}")
-+if(BUILD_EDITOR)
- add_executable(cdogs-sdl-editor cdogsed/cdogsed.c ${CDOGS_SDL_EXTRA})
- if(APPLE)
- set_target_properties(cdogs-sdl-editor PROPERTIES
---
-2.29.2
-
diff --git a/games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Remove-Winline-and-Werror-definitions.patch b/games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Remove-Winline-and-Werror-definitions.patch
deleted file mode 100644
index acd9a4e85769..000000000000
--- a/games-arcade/cdogs-sdl/files/cdogs-sdl-0.10.1-Remove-Winline-and-Werror-definitions.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 2b55a76518e0492d7003af9af798bd9769f0b586 Mon Sep 17 00:00:00 2001
-From: William Breathitt Gray <vilhelm.gray@gmail.com>
-Date: Thu, 10 Dec 2020 07:07:33 -0500
-Subject: [PATCH] Remove -Winline and -Werror definitions
-
----
- CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 510e4802..ed2872b5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -123,7 +123,6 @@ else()
- endif()
- endif()
- if(NOT BEOS AND NOT HAIKU)
-- add_definitions(-Winline -Werror)
- set(EXTRA_LIBRARIES "m")
- endif()
- endif()
---
-2.29.2
-