summaryrefslogtreecommitdiff
path: root/games-arcade/cosmosmash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/cosmosmash
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/cosmosmash')
-rw-r--r--games-arcade/cosmosmash/Manifest5
-rw-r--r--games-arcade/cosmosmash/cosmosmash-1.4.7.ebuild36
-rw-r--r--games-arcade/cosmosmash/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/cosmosmash/Manifest b/games-arcade/cosmosmash/Manifest
new file mode 100644
index 000000000000..af4d487d1ebb
--- /dev/null
+++ b/games-arcade/cosmosmash/Manifest
@@ -0,0 +1,5 @@
+DIST cosmosmash-1.4.7.tar.gz 906213 SHA256 3f0af3355e31fef9413d3c318f02b64ad6c427f0048d6e15868e51a5ac22b14b SHA512 1eaf8b05550c6f96e6392f6ba4565700cd4a9cac66dd57d634569caf9b4dfaf4917b3b9973153d4e6e0ddcd65c68d5242faae7c4f516c07c2e07d1b2f3b838b9 WHIRLPOOL 7234288c3e6a90b5625e203c221e7c662ac6ef7968134c6c1f963d6405812bfbef986179db93c1914010406e1f02312f3059a9722214324f41a2ddbd33c2b668
+EBUILD cosmosmash-1.4.7.ebuild 879 SHA256 bcf6b026242afe9697dddbae5973102ea34340cecb92c4a850d06e506290a507 SHA512 c971b08843f60dc451a97472f6b6d8b2ac2b3f05b0769b2e1065ae242641edb7c982e3c251a9ac8fe68e8f6fe1bac130456e36d9fb6d371c05edaaef7e7f322e WHIRLPOOL 1f257278c8b57814e7d35fc8f8349b7db24b5c82777b690eb5f3d8d9567464b2858d7280c4cf63c54d73168cb1ed1b63f574d303462840ad5f0638f3125a38dd
+MISC ChangeLog 2440 SHA256 06af94665c34a3865c0a85110e99c18b9e3e9a96058528fc2511588029218726 SHA512 7590022ae2eb029e2be9927df612cc061e9f433c8ab3563c47db41b9e51b1f46ed5b42d56d01f2cd4d6cd08523b4c99878cf9d547370d908259191569f246059 WHIRLPOOL a4e30ea4f82bbde42b28e6f3dbc403d3a4f53351a0ea3a110ab5e56e8adaad91866600662449e0f2351c3c682176c7e0a654f77c53bb944e0672d49c0b3c2cf4
+MISC ChangeLog-2015 1805 SHA256 6e4a0a3915db2169a0a888bbd8177fa8075460785532a7351441e964cbb32354 SHA512 29676e3f955bdb37eb11054b173ffb280880bbd3994f66b3156b21d0bb008d14ffdbff72afef29d5136070b146b341483253ec2cad000e8937fba0a51c164155 WHIRLPOOL e0a3e82ce057c8b0d0f7d2bc4948bc5fab4615c00978e583774fb1f410ce728b91d58556037d7cc9ab09c966d2df3b336da91ec8615ad93abc7525a55f707d2d
+MISC metadata.xml 383 SHA256 e5557c7da63f90ccc5c582972d501a020d7485a522859b244f80a4ccd082a688 SHA512 6ac1eca021c30af55b915f3d34d180ad429f9f16e7e942b3853d8f77f0ba82fa8bf97439209414e7541b0c0bfba29b49b1efc143e690ae7f8dbffd1fcaae9986 WHIRLPOOL 3784c1ef2f80e94953e0633d330ff7b1bead1d34cd8d052ce1f3ba71a62a04bf2ff67189b99927f6b4c64295055793b210d144b73cf8f7493bac075f5a5e1b74
diff --git a/games-arcade/cosmosmash/cosmosmash-1.4.7.ebuild b/games-arcade/cosmosmash/cosmosmash-1.4.7.ebuild
new file mode 100644
index 000000000000..d92de90e61bd
--- /dev/null
+++ b/games-arcade/cosmosmash/cosmosmash-1.4.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools games
+
+DESCRIPTION="A space rock shooting video game"
+HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/cosmosmash.html"
+SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="test" # uses the sound card which portage user might not be available.
+
+RDEPEND=">=dev-games/flatzebra-0.1.6"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
+ -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
+ -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
+ src/Makefile.am \
+ || die
+ eautoreconf
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+ doman doc/${PN}.6
+ dodoc AUTHORS NEWS README THANKS
+ prepgamesdirs
+}
diff --git a/games-arcade/cosmosmash/metadata.xml b/games-arcade/cosmosmash/metadata.xml
new file mode 100644
index 000000000000..418dc79f8c64
--- /dev/null
+++ b/games-arcade/cosmosmash/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+Afternoon Stalker, a clone of the 1981 Night Stalker video game by Mattel
+Electronics.
+</longdescription>
+</pkgmetadata>